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Introduction
This FitAllä Reference Guide describes the function of each of the menu selections, provides a 'How to'
section that will help you to make better use of FitAll and has an appendix that provides contact and
additional technical information about FitAll.

What's New
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Analyze

View

Options

Info

Help

How To

Appendix
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What's New
New In FitAll version 10

New In FitAll version 9

New In FitAll version 8
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New In FitAll version 10
FitAll version 10 has been enhanced to include the following new features:

? NEW: A Scripted Functions feature has been added. 
This makes is possible for you to add up to 100 functions to FitAll by filling out a simple form.

The advantages are:
(i) You can quickly add single-line custom function expressions to FitAll without the need for a
compiler.
(ii) Each function can contain one independent variable, X, and up to ten  (10) parameters, P,

The disadvantages are:
(i) FitAll will not be able to automatically determine the initial parameter estimates that are required
when analyzing nonlinear functions.
(ii) The regression analysis will be slower than if the function had been compiled into a FitAll function
library

? NEW: Almost all forms and dialogs now use the font that is set via the new Options > Change Font
menu selection.
This makes it easier to read the text on small, high resolution monitors.

? IMPROVED: Most dialogs and forms have been modified to make them easier to read.
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? CHANGED: FitAll Function Libraries can only be modified and compiled using the Lazarus / Free
Pascal Compiler, which is a free, open source Object Pascal compiler.
Support for the Delphi compiler was discontinued because most users found it to be too costly. 

? DISCONTINUED: Support for MS Windows Vista and earlier has been discontinued because they
are no longer supported by Microsoft.

? DISCONTINUED: Support for ActiveX / COM Automation.
That is, FitAll can no longer act as an automation server and be controlled by other programs using
ActiveX / COM automation.
(This was done because no current FitAll users are using or even contemplating using this feature.)

http://www.lazarus.freepascal.org/
http://www.lazarus.freepascal.org/
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New In FitAll version 9
FitAll version 9 has been enhanced to include the following new features:

· FitAll now takes advantage of some of the features that were introduced in MS Windows 8.1 and 10.

The most noticeable change is that FitAll now will automatically adjust the font and images sizes
when it is run on a computer with a high resolution monitor or its main window is moved to a monitor
that has a different resolution.

· The FitAll  API now has functions to determine the roots of 2nd  to 10th -order polynomials.

· The FitAll Chemistry Functions Library now has many new functions that can be used to determine
the concentration, and acid dissociation constants, pKa's, of weak monoprotic, diprotic and triprotic
acids as well as mixtures of monoprotic acids when titrated with a strong base. All of the solutions
may or may not contain a strong acid, the concentration of which also can determined.

· FitAll can now display help documents for the User Defined Functions, UDFs, that you have
created.

This makes it possible for you, your colleagues and your students to get some help for the functions
that you developed.

The help files can be MS Word (*doc, *.docx), Rich Text (*.rtf), Open Document Text (*.odt), Text
(*.txt) or Portable Document Format (*.pdf) files

· Support for MS Windows XP has been discontinued.
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New In FitAll version 8
FitAll version 8 has been enhanced to include the following new features:

· The most noticeable change is to the main user interface, which is of the "tabbed notebook" type
rather than the previous "multi-document" type.

This makes it easier to see which windows are open and to switch between them. The tabs may,
optionally, include a small icon (graphic) that indicates whether the tab contains text or a graph.

· Switching the X- (bottom) and Y- (left) axes has been improved to ensure that the axis captions are
properly switched.

· .All of the Solar Cell functions have been extended so that they can be used to analyze IV data
obtained from "modules" as well as from "single cells".

Previously, for a module with the solar cells connected in series, it was necessary to divide the
measured voltage values by the number of cells. Now, an adjustable constant, Ns, can be set to the
number of cells that are connected in series and the unmodified data can be directly analyzed.
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A similar situation also applies to modules in which the solar cells are connected in parallel.

· Several new functions, including but not limited to GammaP, GammaQ, IsInfinite, IsNAN, IsZero,
Sinh, Cosh, Tanh, have been added to the FitAll API. This makes it easier for programmers, who
are adding their own functions to FitAll Research Edition, to more easily add more complicated
functions of their own.

· FitAll now makes more efficient use of the computer's memory.

· FitAll now makes more efficient use of the computer's memory.

· MS Windows 8 is now supported.

· MS Windows 2000 support has been discontinued.
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New

Choose File > New, press Ctrl+N or click the  button to create a new set of data.

When you select File > New, the 'New Data' dialog box appears. It looks like this:

Click the Ok button to accept your choices or click the Cancel button if you decide not to create a new
data set.

FitAll will then switch to the Data window, which will contain one data point.

An initial value of zero is assigned to the number in each column, with the exception of the last column,
the SigmaY column, which may be assigned a value of one (See: Options > Preferences > Set new
SigmaY's to 1.0 ).

To add another data point at the end of the list, press the Insert key or choose Edit > Add point .

After entering your data, save it to disk before doing anything else. This will minimize the possibility of
accidental data loss.

NOTE:
You can quickly and easily spot data entry errors by plotting the data graph .

Title

Enter a title for your data set in the Title edit field.

FitAll will use this as the default title for graphs.

Sub-Title

Enter a sub-title for your data set in the Sub-Title edit field.

128

35

108
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Number of columns

Use this spin-edit box to set the number of data columns.

Each data set must have at least three data columns, which hold the X, Y and SigmaY data.

If you only have data for the X and Y columns, choose three columns, anyway.

Initially, the maximum number of data columns is limited to eight. If you need more, use the Options >
Preferences > Max data columns  setting to set a higher value.

NOTE:
The amount of memory that your computer has may limit the size of data sets
that you can use.

Data Column names

Enter a name for each data column.

To enter a new column name:

· Click on the column name that you want to change.

· Type in that name you want.

· Press the Enter key to accept your change, or press the Esc key to cancel it.

To edit a column name:

· Double click the column name you want to edit, or highlight it and press the F2 key.

· Make the changes the you want.

· Press the Enter key to accept your change, or press the Escape key to cancel your change.

Def. names

Click this button to have FitAll assign default names to the data columns. The assigned column names
will be "X1", "X2", ..., "Y", and "SigmaY".

127
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Open

Choose File > Open, press Ctrl+O or click the  button to retrieve data from a disk file (See: Opening a
Data File in the Getting Started Guide).

Opening a data file replaces the data currently in memory with that from the disk file.

If the data currently in the computer's memory has not been saved or if it has changed since it was last
saved, you will be asked whether to save it before it is replaced by the new data.

NOTE:
FitAll normally expects data files to have the file name extension ".DTA". If you
choose to open a file with a different file name extension, FitAll will still read it as
long as it has the correct structure (See: DTA Files  in the Appendix).

Also See
File > Import Text Data...

File > Join...

File > Reopen...

192

12

17

16
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Import text data ...
Choose File > Import Text Data... to retrieve data from a disk text file that has a structure that does not
correspond to the standard ".dta" format.

NOTE:
The structure of "Comma Separated Values", CSV, data files is best regarded as
a "pseudo standard".

Depending on which program generated the ".CSV" data file, the characters used
to enclose, quote, text values, to separate data values and to indicate the decimal
position in numeric values may differ.

The "Import Text Data" makes it possible to import the data from such files into
FitAll.

The general file structure that can be imported is described in the Appendix as XXX Data Files .

When you click the  menu selections File > Import Text Data... a dialog like the following will appear.

200
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Click the "Browse" button and open the data file that you want to import into FitAll.

The result could look like this:
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After viewing the first five lines of the file contents, change the "Quote Character", "Separator Character"
and "Decimal Character" to appropriate values.

In the above example, the result should look like this:
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Click the OK button to import the data.

Opening a data file replaces the data currently in memory with that from the disk file.

If the data currently in the computer's memory has not been saved or if it has changed since it was last
saved, you will be asked whether to save it before it is replaced by the new data.

NOTE:
After the data is imported, FitAll will change the file name extension to ".DTA". 
This is done so that when the data is next saved it will be saved in the standard
FitAll data format.

Also See
XXX Data Files

DTA Data Files

200

192
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Reopen...
Choose File > Reopen recent to retrieve a data set that you have recently used.

NOTE:
Depending on which Preferences  are set, the File > Reopen recent... menu
selection may or may not be available.

Also See
File > Open...

129

11
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Join...
Choose File > Join to append data from an existing file to the data in memory.

The number of data columns in the file must be the same as the number of columns in the data set that is
in your computer's memory.

After joining a set of data, you will probably want to sort it using the Edit > data Sort  menu selection or
right click in the data window and choosing data Sort... from the context menu.

48
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Save

Choose File > Save, press Ctrl+S or click the  button when the Data window has the focus to save the
data, that is in your computer's memory, to a disk file.

NOTE:
This menu selection is only available when the Data window is active and the
data has changed since it was last saved.

The data will be saved with its current file name.

To save the data with a different file name, select the File > Save as...  menu choice or click the 
button on the toolbar.

NOTE:
The contents of other windows, for example, the data graph or the results window
also can be saved to disk using the File > Save as...  menu selection.

Also See
File > Save as...

19

19

19
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Save as...

Data window

When the Data window is active, FitAll will automatically add the ".DTA" extension, if you do not specify a
file name extension.

If you specify an extension other than ".dta", FitAll will save it in the same format as a DTA  file unless
you specify a ".CSV"  , ".SDF " or ".TDF"  extension (See: File Structures  in the Appendix). 

Windows Containing Text

When the active window contains text, such as the Results window, FitAll will suggest a file name based
on the data file name and the window's name. The contents of the window will then be saved as a
standard ASCII text file.

If you change the file name extension to something other than ".txt", FitAll will still save the contents of the
window as a standard ASCII text file.

Windows Containing A Graph

When the active window contains a graph, such as the data graph window, FitAll will suggest a file name
based on the data file name and the window's name.

By default, the file name extension will be ".emf". The ".emf" extension indicates that the graph will be
saved as a Windows Enhanced Meta file. Many Windows programs can import graphics files that use this
format.

FitAll can save graphs as a: 

· Bitmap (.bmp) file.

· Graphics Interchange Format (.gif) file.

· JPEG (.jpg) file, which easily can be incorporated into web pages.

· Portable Network Graphics (.png) file.

192

194 198 196 192
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Print to clipboard
Choose File > Print to clipboard or press Ctrl+Alt+C to copy the contents of the active window to MS
Windows' Clipboard.

If the active window is a text window, such as the 'Data' or 'Fit' windows, its contents will be copied to the
clipboard.

If the active window is a graph window, such as the 'data graph' or 'fit graph' windows, its contents will be
copied to the clipboard as a 'Picture' (a bitmap). Pictures can be 'pasted' into many Windows applications,
including word processors such as MS Word for Windows and LibreOffice Writer.

NOTE:
For graph windows in FitAll, this command does the same thing as the Edit,
Copy  command.

For windows that contain text, printing to the clipboard copies the window's column
and row headings as well as the column values.

Also See

Edit > Generate Report

28

73
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Close current tab

Choose File > Close current tab, press Ctrl+L or click the  button at the right end of the toolbar to close
the currently active tab/window.

Also See

File > Close all tabs 22
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Close all tabs
Choose File > Close all tabs or press Ctrl+Alt+L to close all currently open tabs/windows.

Also See

File > Close current tab 21



- 23 -

Reference Guide File, Exit

Exit
Choose File > Exit or press Alt+F4 to quit FitAll and return to Windows.

If the data in memory has not been saved since it was last modified, you will asked whether you want to
save it before quitting.
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Cut

Choose Edit > Cut, press Ctrl+X or click the  button to delete the selected data points in the Data
window and copy them to the Windows Clipboard.

The Edit > Cut and Edit > Paste  selections can be used together to change the order of the data points
in the data set. You might, for example, want to move one or more 'bad' data points out of the analysis
range without actually deleting them from the data set.

NOTE:
This command is available only when the 'Data' window is active and one or more
data points are selected.

To select a row of data click on the 'Row row number'. You can use the Shift key to select more than one
row.

For example:

· Click on the row number 1.

29
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· Hold down the Shift key and click on the Pt# number three (3). The result should look like this:
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NOTE:
You also can select rows of data using the shift and arrow keys.
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Copy

Choose Edit > Copy, press Ctrl+C or click the  button to copy the selected text in the Data Window or
the graph in a graph-containing window to the Windows Clipboard.

Also See

Edit > Generate Report

File > Print to clipboard

73

20
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Paste

Choose Edit > Paste, press Ctrl+V or click the  button to copy data points from MS Windows' Clipboard
to FitAll's Data window.

NOTES:

1. The Data window is the only window in FitAll into which data can be pasted.

2. If there are fewer columns of data in the text that is to be pasted than are
present in the current data set, the additional columns will be assigned a value
of 1.0 or 0.0 depending on the Set new SigmaY's to 1.0  setting on the
Options > Preferences  menu.

3. If one or more rows of data are selected, the pasted data will replace selected
rows of data.

4. If all the data rows are selected

(a) And the first column of the first row of the text to be pasted contains a
column heading, rather than a number, the headings also will be pasted into
FitAll.

(b) And the text to be pasted only contains numbers, the column headings in
FitAll will not be changed.

(c) And the pasted data contains a different number of columns, the number
of data columns in FitAll will be adjusted to match the number of columns in
the pasted data.

Also See

Edit > Copy

Edit > Cut

128

126

28

25
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Delete

Choose Edit > Delete, press Delete or click the  or  buttons to delete the selected data points in the
Data window.

To select a row of data click on the 'Row row number'. You can use the Shift key to select more than one
row.

For example:

· Click on the row number 1.
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· Hold down the Shift key and click on the Pt# number three (3). The result should look like this:
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NOTE:
You also can select rows of data using the shift and arrow keys.
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Select all
Choose Edit > Select all or press Ctrl+A to select all of the data points in FitAll's Data window.

Also See

Edit > Unselect all .34
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Unselect all
Choose Edit > Unselect all or press Ctrl+U to de-select all of the text in a text containing window, such as
the Data window.

Also See

Edit > Select all .33
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Row(s) Add

Click Edit > Add point (row), press the Insert key or click the  button to add (append) a data point to the
end of the data set.

The initial values in all the columns will be zero, with the possible exception of the last column.

The value in the last data column, the SigmaY column, may be one or zero, depending on the Options >
Preferences > Set new SigmaY's to 1.0  setting.

To enter the values you actually want:

· Click on the value you want to change or use the arrow keys to highlight it.

·  Type in the new value or press the F2 key to edit the value.

·  Press the Enter key.

For a more detailed example, see Entering and Editing Data in the Getting Started Guide.

128
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Row(s) Delete

After selecting one or more rows of data, choose Edit > Delete, press the Delete key or click the  button
to delete the 'selected' data point(s) in the Data window.

To select a row of data click on the 'Row row number'. You can use the Shift key to select more than one
row.

For example:

· Click on the row number 1.
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· Hold down the Shift key and click on the Pt# number three (3). The result should look like this:
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NOTE:
You also can select rows of data using the shift and arrow keys.
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data Modify...
Choose Edit > data Modify... or press Alt+M to modify your data one column at a time.

NOTE:
This menu selection is available only when there is data available and the 'Data
window' is the active window.

When you choose Edit > data Modify... the 'Modify data' dialog box appears. It looks like this:

To modify a column of data:

· Choose one of the three equations shown in the Modify data dialog box by clicking the top, middle or
bottom radio button at the left side of the dialog box.

· Use the Result Column drop-down list to choose the data column into which the results of the
calculations will be placed.

· Use the Column A and Column B drop-down lists to choose the data columns that will be used in the
calculation.

· Use the Operation drop-down list to choose the arithmetic operation that will be performed. The
available operations include such arithmetic operations as: absolute value, multiply, divide, Log, Ln and
exponential to the base 10 or base e.

· Use the 'New result column name' edit box to assign a new name (title) to the result column.

· Click the Calculate button to do the calculation.

· Repeat the steps above to make additional data modifications.

· Click the Done button.
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One column operations

· 1% Full Scale Setting: Each element of the Result column is replaced by one percent of the full-scale
setting of the value in Column B; that is, R = 0.01*FSS(B).

The full-scale setting is determined by rounding the absolute value of B to the next highest power of ten.

For example:
for B-values from 0.0100 to 0.0999 the FSS is 0.1,
for B-values from 0.100 to 0.999 the FSS is 1.0 and 
for B-values from 1.00 to 9.99 the FSS is 10.

This may be useful in estimating the error (precision) of measured Y-values when the Y-values in one
experiment span several orders of magnitude.

NOTE 1:
Typical measurement instruments, such as (auto-ranging) voltmeters, often have
a precision that is directly proportional to their full-scale setting.

NOTE 2:
FitAll has a weighting factor called 1/(0.01*FSS) 2  that will automatically
calculate and use the FSS when weighting the regression analysis.

· 1/: Each element of the Result column is replaced by the reciprocal of the value in Column B; that is, R
= (1/B).

· 10^: Each element of the Result column is replaced by 10 raised to the power of the value in Column B;
that is, R = 10B.

· Abs: Each element of the Result column is replaced by the positive value of the value in Column B; that
is, R = |B|.

· ArcCos: Each element of the Result column is replaced by the ARCCOSINE of the value in Column B;
that is, R = ArcCos(B).

· ArcSin: Each element of the Result column is replaced by the ARCSIN of the value in Column B; that
is, R = Arcsin(B).

· ArcTan: Each element of the Result column is replaced by the ARCTANGENT of the value in Column
B; that is, R = ArcTan(B).

· Cos: Each element of the Result column is replaced by the COSINE of the value in Column B; that is, R
= Cos(B). The Column B values are assumed to be in radians.

95 95
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· Cube: Each element of the Result column is replaced by the cube of the value in Column B; that is,
R=B3.

· Cube root(: Each element of the Result column is replaced by the cube root of the value in Column B;
that is, R = B(1/3).

· Degrees to Radians: Each element of the Result column is replaced by 2p times the value in Column
B; that is, R = B * 2p.

· Exp: Each element of the Result column is replaced by e raised to the power of the value in Column B;
that is, R = eB.

· FFT: Each element of the Result column is replaced by the Fast Fourier Transform (FFT) of the value
in Column B; that is, R = FFT(B).

The FFT procedure assumes that:

1. The data to be analyzed contains an integer power of two (that is, 2i) data points to a maximum
of 65,536 (which is equal to 216) points. If it does not, FitAll will, during the calculations, append
a sufficient number of data points with a value of zero so that there are 2i data point to analyze.
For example, if the actual data set contains 200 data points, FitAll will append 56 data points
with a value of zero so that there are a total of 256 (= 28) data points to analyze.

2. All the data are "real"-valued.

3. The data were collected at a constant interval, D. For example if the time between each
measurement was ten seconds then D = 10 s.

The simplest way to display the results of the FFT transform is to plot the FFT values versus the
Point Number in a data graph.

The frequency at each data point can be calculated using the formula:

f(i) = (i-1) / (2 * N * D), in which 

i is the point number, which has values from 1 to Npts,

N is the number of data points that FitAll used in its calculations. For example, if the data set
contains 200 data points, the value of N is 256, which is the smallest integer power of two that is
greater than or equal to the number of data points in the data set, and

D is the time difference between two adjacent data points.

· FFT*: Each element of the Result column is replaced by the Inverse Fast Fourier Transform (FFT*) of
the value in Column B; that is, R = FFT*(B).

The FFT* procedure makes the same assumptions as the FFT procedure.
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NOTE:
If an inverse FFT, FFT*, is applied to the result of the FFT of a column of data the
final result will not be identical to the original data.

This is because the FFT calculates the amplitude at a finite number of
frequencies.

· Hours to Minutes: Each element of the Result column is replaced by 60 times the value in Column B;
that is, R = B*60.

· Hours to mS: Each element of the Result column is replaced by 3,600,000 times the value in Column
B; that is, R = B*3600000.

· Hours to Secs: Each element of the Result column is replaced by 3,600 times the value in Column B;
that is, R = B*3600.

· Ln(Abs(: Each element of the Result column is replaced by the natural logarithm of the value in Column
B; that is, R = Ln|B|.

· Log(Abs(: Each element of the Result column is replaced by the base ten logarithm of the absolute
value in Column B; that is, R=Log|B|.

· Minutes to Hours: Each element of the Result column is replaced by 1/60 times the value in Column B;
that is, R = B/60.

· Minutes to mS: Each element of the Result column is replaced by 60,000 times the value in Column B;
that is, R = B*60000.

· Minutes to Secs: Each element of the Result column is replaced by 60 times the value in Column B;
that is, R = B*60.

· mS to Hours: Each element of the Result column is replaced by 1/3,600,000 times the value in Column
B; that is, R = B/3600000.

· mS to Minutes: Each element of the Result column is replaced by 1/60,000 times the value in Column
B; that is, R = B/60000.

· mS to Seconds: Each element of the Result column is replaced by 1/1,000 times the value in Column
B; that is, R = B/1000.
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· Radians to Degrees: Each element of the Result column is replaced by 1/(2p) times the value in
Column B; that is, R = B / 2p.

· Random Number: Each element of the Result column is replaced by a (pseudo) random number such
that the average of the values is zero, 0, and the standard deviation is 1.0.

· Sin: Each element of the Result column is replaced by the SINE of the value in Column B; that is, R =
Sin(B). The Column B values are assumed to be in radians.

· Secs to Hours: Each element of the Result column is replaced by 1/3,600 times the value in Column B;
that is, R = B/3600.

· Secs to Minutes: Each element of the Result column is replaced by 1/60 times the value in Column B;
that is, R = B/60.

· Secs to mS: Each element of the Result column is replaced by 1,000 times the value in Column B; that
is, R = B*1000.

· Square: Each element of the Result column is replaced by the square of the value in Column B; that is,
R = B2.

· Square root(Abs(: Each element of the Result column is replaced by the square root of the value in
Column B; that is, R = Ö|B|.

· Tan: Each element of the Result column is replaced by the TANGENT of the value in Column B; that is,
R = Tan(B). The Column B values are assumed to be in radians.
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Two column operations

· Add: Each element of the Result column is replaced by the sum of the values in Column A and B, that
is R = A + B.

· Differentiate wrt: Each element of the Result column is replaced by the derivative of the value in

Column A taken with respect to the value in Column B; that is, R = / B.

The derivative is calculated using a 'natural' cubic spline. This is equivalent to using a sliding second-
order polynomial.

The derivatives at the first and last points are calculated using linear interpolation. The data are
assumed to be sorted on Column B.

· Divide by: Each element of the Result column is replaced the values in Column A divided by the value
in Column B; that is, R = A / B.

· Integrate wrt: Each element of the Result column is replaced by the area under the curve of a plot of

the values in Column A vs. the values in Column B; that is, R = .

The area (integral) is calculated using linear interpolation (the trapezoid rule). The incremental change
in the area for the ith data point is given by: (Ai + Ai-1) * (Bi - Bi-1) /2.

The data are assumed be sorted on Column B.

· Multiply by: Each element of the Result column is replaced product of the values in Column A and B;
that is, R = A * B.

· Polar ΘR to X: Each element of the Result column is replaced by the Cartesian Coordinate value X
from the Polar coordinates Theta, Θ, and R; that is, Result = B*Cos(A).

It is assumed that Column A contains the Θ values and Column B contains the R values.

It is essential that the Result Column is not either column A or B.

· Polar ΘR to Y: Each element of the Result column is replaced by the Cartesian Coordinate value X
from the Polar coordinates Theta, Θ, and R; that is, Result = B*Sin(A).

It is assumed that Column A contains the Θ values and Column B contains the R values.

It is essential that the Result Column is not either column A or B.

· Subtract: Each element of the Result column is replaced by the difference between the values in
Column A and B; that is, R = A - B.
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· XY to Polar R: Each element of the Result column is replaced by the Polar coordinate Radius value, R,
2 + B2).

It is assumed that Column A contains the X values and Column B contains the Y values.

It is essential that the Result Column is not either column A or B.

· XY to Polar Θ : Each element of the Result column is replaced by the Polar coordinate Theta value, Θ,
from the Cartesian coordinate values X and Y; that is, Result = Arctan2(B, A).

It is assumed that Column A contains the X values and Column B contains the Y values.

It is essential that the Result Column is not either column A or B.
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One column and a constant operations

· ^(Integer power): Each element of the Result column is obtained by raising the value in Column A to
the power of the constant; that is, R = Aconst.

The constant value must be an integer (whole) number. If it is not, FitAll will round it to the nearest
whole number.

· Abs()^: Each element of the Result column is obtained by raising the absolute value of the
corresponding value in Column A to the power of the constant; that is, R = |A|const.

The constant value can be a fraction; that is, it does not have to be a whole (integer) number.

· Add: Each element of the Result column is the sum of the corresponding element in Column A and the
constant; that is, R = A + Const.

· Divide by: Each element of the Result column is the dividend of the corresponding element in Column
A and the constant; that is, R = A / Const.

· Limit <=: Each element of the Result column is set to the corresponding value in column A if it is less
than or equal to 'The Constant'; otherwise it is set to 'The Constant' value; that is, R = A if A <= Const
otherwise R = Const.

· Limit >=: Each element of the Result column is set to the corresponding value in column A if it is
greater than or equal to 'The Constant'; otherwise, it is set to 'The Constant' value; that is, R = A if A is
>= Const otherwise R = Const.

· Rnd to N sig. figs.: Each element of the Result column is obtained by rounding the value in Column A
to N significant figures.

The constant value must be an integer (whole) number between 1 and 20. If it is not, FitAll will round it
to the nearest whole number.

· Subtract: Each element of the Result column is the difference of the corresponding element in Column
A and the constant; that is, R = A - Const.

· Multiply by: Each element of the Result column is the product of the corresponding element in Column
A and the constant; that is, R = A * Const.

· Smooth Boxcar: Smooths one column of data by averaging the "Constant" number of adjacent data
points.

The constant you specify will be rounded to the nearest whole (integer) number.

If you enter a value of one, 1, for the constant no smoothing will be done.
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· Smooth FFT: Smooths one column of data using a Fast Fourier transform (FFT) as a 'low pass filter'.
When you choose this type of smoothing, the 'Constant' value determines the 'amount of smoothing'.
This number is approximately equivalent to the number of data points that are 'averaged'.

The number that you enter does not have to be an integer. For example, 3, 3.5 and 6.27 are acceptable
values for the constant.

If you enter zero, 0, no smoothing will be done.

FitAll assumes that the data are sorted on the independent variable. That is, when smoothing the Y-
data, it is assumed that the data has been sorted on X.

FFT smoothing is restricted to data sets with 2,097,152 or fewer data points.

· Rotate X CC Degrees: Modifies the values of the specified column assuming that it contains X-values
and the corresponding Y-values are specified by the data set's Y-values; that is, the second last data
column.

The resulting values will correspond to the values obtained if the X and Y axes are rotated in a counter-
clockwise direction by the specified number of degrees.

It is very important that the Result column is NOT the current X, or a specified, column. 

Prior to applying this data modification create a new data column and specify the new column as the
Result column.

The reason for doing the above is that it is more than likely that you also will want to rotate the Y-values
and the Y-value rotation requires the original X-values.

· Rotate Y CC Degrees: Modifies the values of the specified column assuming that it contains Y-values
and the corresponding X-values are specified by the data set's X-values; that is, the first data column.

The resulting values will correspond to the values obtained if the X and Y axes are rotated in a counter-
clockwise direction by the specified number of degrees.

It is very important that the Result column is NOT the current Y, or a specified, column. 

Prior to applying this data modification create a new data column and specify the new column as the
Result column.

The reason for doing the above is that it is more than likely that you also will want to rotate the X-values
and the X-value rotation requires the original Y-values.
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data Sort...
Choose Edit > data Sort... to sort your data.

When you choose Edit > data Sort the 'Sort data on column' dialog box appears. It looks like this:

· Click the name of the column on which you want to sort the data.

· If you want to sort only some of the data, change the "First Pt." and "Last Pt." values to reduce the range
of data points that will be sorted. By default all of the data points will be included in the sort operation.

· Click the OK button.

NOTE:
When FitAll does automatic initial estimates of the parameter values it normally
expects the data to be sorted on the first, X, data column.
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data Titles...
Click the Edit > data Titles... menu selections or press Ctrl+T to edit the data set's titles.

The 'Data Titles and Column Headings' dialog box will appear. It should look like this:

Title

Use the 'Title' edit box to enter a title for the data set.

Sub-Title

Use the 'sub-Title' edit box to enter a sub-title for the data set.

Data Column Names

Use the 'Data Column Names' table to change the data column names.

Use the up and down arrow keys to highlight the name you want to change. Type in the new column
name.

Def. Names

Click the "Def. Names" button to set the data column names to "X1, X2, ..., Y, SigmaY".
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column Delete

After selection on or more data columns, choose Edit > column Delete or click the  button to delete
selected columns of data.

To select a data column click on the column title. The column will be highlighted. The data window may
look like this:

NOTE:
You also can select columns of data using the shift and arrow keys.

NOTE:
Since a FitAll data set must have at least three data columns, FitAll will only
delete a column of data if there are at least four columns in the current data set
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column Fill...
Choose Edit > column Fill... to set all of the data values in one column at once.

When you choose Edit > column Fill... the 'Fill a data column with values' dialog box appears. It looks like
this:

· Select (highlight) the name of the column, that is to be filled with values, in the list box at the left side of
the dialog.

· Change the value in the "First Pt." spin edit control as appropriate.

· Change the value in the "Last Pt." spin edit control as appropriate.

· Enter a starting value in the 'Start value' edit box.

· Enter a step size in the 'Step size' edit box.

· Click the OK button.

The result could look like this:
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column Insert

Choose Edit > column Insert or click the  button to insert a new data column into the data set that is
currently in memory.

NOTE:
This option is only available when the 'Data window' is the active window.

After choosing this menu selection the data window may look like this:

NOTE:
The new column is automatically inserted as the third last column in the data set
and all of its values are zero. This corresponds to the last of the independent
variable columns.

If you want the new column at a different location, you can change its position using the Edit > column
Move...  menu selection or by selecting the column heading and dragging it to its new position.54
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column Move...
Choose Edit > column Move... to change the order of the data columns in the data set that is currently in
memory.

NOTE:
This option is only available when the 'Data window' is the active window.

When you choose Edit > column Move... the 'Move data columns' dialog box appears. It looks like this:

· Select one of the columns in the listbox at the left of the dialog by clicking on it.

· Click either the Up or Down button to change the position of the currently selected column.

· Click the OK button when the columns are in the order that you want them.

It also is possible to "drag" a column from one position to another. Here's how to do it:

· Click on the title of the column that you want to move. (This will select/highlight it).

· "Click and drag" the column title to its new position.

· Release the mouse button.
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Generate data set...
Choose Edit > Generate data set... to create a set of data that is calculated using one of FitAll's defined
functions with the constants and parameters of your choice.

Use this menu selection to create sample data sets or data sets that can be used as calibration curves.

When you choose Edit > Generate data set... the 'Generate new data set' dialog box appears. It looks like
this:

and has five tabs -- Function , Constants , Parameters , Variables  and Noise .

· Click on each of the tabs in turn and change the settings to what you want them to be.

· Click the OK button.

56 57 57 58 58
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Function

Ftn Category

Use the Ftn Category drop down list to restrict (limit) the list of selectable functions.

NOTE:
Only the functions in the category that you select will be displayed in the Function
drop down list.

Function

Use the Function drop down list to select the function that you want to use to generate a new set of data.

If more than one variation of the function is available, one or more dialog boxes requesting additional
information will appear. In each dialog, enter an appropriate value and click the OK button.

Help for Current Function, 

Click the  button to display Help for the currently selected function.

Data Title

Use the Data Title edit box to enter a title for the data set.

Data Sub-Title

Use the Data Sub-Title edit box to enter a sub-title for the data set.

Number of points to generate

Use the 'Number of points to generate' spin-edit box to enter the number of data points that should be
calculated.

The minimum value is two (2) and the maximum value depends on the Preferences, Max. data points
setting.

126
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NOTE:
The Variables  tab is used to set the minimum and maximum values of the X-
variables (that is, the independent variables) that will be used in the calculation.

If you are going to have the X-values range from 0 to 10 then set the number of
data points to 11 so that the actual X-values are 0, 1, 2, ..,, 10.

Space Logarithmically

Check this item if you want the first X-variable's spacing between the calculated data points to be
logarithmic.

This is useful if graphs of the data usually use a logarithmic scale.

Space All Logarithmically

Check this item if you want all of the X-variables' spacings between the calculated data points to be
logarithmic. (This assumes that there is more than one X-variable.)

Generate Data SigmaY

Check this item if you want FitAll to use the parameter standard deviations from the last analysis to
calculate the estimated error (standard deviation) of the calculated Y-values.

Constants

Name

Initially, the names displayed in the 'Name' column are the current default constant names for the selected
function. You can change the names to whatever you want.

Value

Initially, the values displayed in the 'Value' column are the current constant values for the selected
function. You can change the values to whatever you want.

Parameters

58
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Name

Initially, the names displayed in the 'Name' column are the current default parameter names for the
selected function. You can change the names to whatever you want.

Value

Initially, the values displayed in the 'Value' column are the current parameter values for the selected
function. You can change the values to whatever you want.

Variables

Name

Initially, the names displayed in the 'Name' column are the current independent variable names for the
selected function. You can change the names to whatever you want.

Min. Value

When FitAll generates a data set, it uses the 'Number of points to generate' value, the 'Min. Value' and
the 'Max. Value' of each of the independent, X, variables to calculate a set of equally space independent
variable values at which the function will be evaluated.

Use the 'Min. Value' edit box to set the smallest value of the independent variable.

Max. Value

Use the 'Max. Value' edit box to set the largest value of the independent variable.

Noise
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Add random errors (noise) to Y

Select this check box to have FitAll generate a set of errors that will be added to the calculated values of
Y. The absolute value of the errors will be placed in the 'SigmaY' data column.

Do not check this box if you are generating a set of data to be used for a calibration plot.

Reset random number generator

Select this check box if you want FitAll to initialize the random number generator just before the data set
is calculated.

In most circumstances this item should not be checked.

Add noise (random errors) to Y as

Use these radio button to choose how you want the noise values calculated before they are added to the
Y-value. The noise values also are stored in the last data column, the SigmaY column.

There are three choices:

· N: For each data set, a set of random numbers is generated with the desired standard deviation and an
average of approximately zero. The specified average is then added to each of the noise values. The
result is then added to the Y-value.

· N*0.01*Y: For each data set, a set of random numbers is generated with the desired standard deviation
and an average of approximately zero. The specified average is then added to each of the noise values.
These values are then multiplied by 0.01 (i.e., 1%) and the Y-value. The result is then added to the Y-
value.

Noise values of this type can be used to approximate measurement errors that are proportional to the
value of the (measured) independent variable, Y.

· N*0.01*YFS Setting: For each data set, a set of random numbers is generated with the desired
standard deviation and an average of approximately zero. The specified average is then added to each
of the noise values. These values are then multiplied by 0.01 (i.e., 1%) and the 'Full Scale Yrange'
value. The result is then added to the Y-value.

Noise values of this type can be used to approximate instrumental measurement errors that are
proportional to the full-scale range setting typical of most measurement equipment.

The full-scale range setting is determined by rounding the absolute value of Y to the next highest power
of ten.

For example:

for Y-values from 0.0100 to 0.0999 the YFSRange is 0.1,

for Y-values from 0.100 to 0.999 the YFSRange is 1.0 and 

for Y-values from 1.00 to 9.99 the YFSRange is 10.

NOTE:
If the Y-values in the data span more than an order of magnitude, this type of
noise is probably the most representative of the actual experimental noise.

Also, when fitting the data it is likely most appropriate to use a weighting factor of 1/Y2.
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Std. Dev. of Noise (NSD)

Use the 'Std. Dev. of Noise (NSD)' edit box to set the standard deviation of the random numbers (noise)
that will be added to the dependent, Y, variable values. These values also will be placed in the 'SigmaY'
data column, that is, the last data column.

Average Noise Value

Use the 'Average noise value' check and edit boxes if you want the average of the added noise values to
differ from (approximately) zero.

Limit Y-Values

Use the "Use Limits" check box to determine whether FitAll will place limits on the Y-value.

Use the Min and Max edit boxes to set the values of these limits.

Depending on the size of the random errors (noise) being added to the Y-value, the final Y-value could
end up having an unrealistic or physically meaningless value or a value that would exceed the range of the
'hypothetical' instrument that is making the measurements.

For example, adding a negative value of the noise to a very small Y-value might produce a negative result
which may be physically impossible. In such a case, it would be useful to set the minimum value to zero.
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Generate Monte Carlo data sets...
Choose Edit > Generate Monte Carlo data sets to create one or more sets of data using one of the
functions and the values of your choice for the parameters, constants and noise.

The values of the independent variable(s), X, used when generating the data are obtained from the data
currently in memory.

When you select Edit > Generate Monte Carlo data sets, the 'Generate Monte Carlo data sets' dialog box
appears. It looks like this:

and has five tabs -- Function , Constants , Parameters , Noise  and Monte Carlo .

Click on each of the tabs in turn and change the settings to what you want, then click the OK button.

62 63 64 65 67
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Function

Ftn Category

Use the Ftn Category drop down list to restrict (limit) the list of selectable functions.

NOTE:
Only the functions in the category that you select will be displayed in the Function
drop down list.

Function

Use the Function drop down list to select the function that you want to use to generate the new data sets.

If more than one variation of the function is available, one or more dialog boxes requesting additional
information will appear. In each dialog, enter an appropriate value and click the OK button.

Help for Current Function, 

Click the  button to display Help for the currently selected function.

Data Title

Use the Data Title edit box to enter a title for the data sets.

Data Sub-Title

Use the Data Sub-Title edit box to enter a sub-title for the data sets.
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Constants

Name

Initially, the names displayed in the 'Name' column are the current default constant names for the selected
function. You can change the names to whatever you want.

Value

Initially, the values displayed in the 'Value' column are the current constant values for the selected
function. You can change the values to whatever you want.
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Parameters

Name

Initially, the names displayed in the 'Name' column are the current default parameter names for the
selected function. You can change the names to whatever you want.

Value

Initially, the values displayed in the 'Value' column are the current parameter values for the selected
function. You can change the values to whatever you want.
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Noise

Add random errors (noise) to Y

Select this check box to have FitAll generate a set of errors that will be added to the calculated values of
Y. The absolute value of the errors will be placed in the 'SigmaY' data column.

Do not check this box if you are generating a set of data to be used for a calibration plot.

Reset random number generator

Select this check box if you want FitAll to initialize the random number generator just before the data set
is calculated.

In most circumstances this item should not be checked.

Add noise (random errors) to Y as

Use these radio button to choose how you want the noise values calculated before they are added to the
Y-value. The noise values also are stored in the last data column, the SigmaY column.

There are three choices:

· N: For each data set, a set of random numbers is generated with the desired standard deviation and an
average of approximately zero. The specified average is then added to each of the noise values. The
result is then added to the Y-value.

· N*0.01*Y: For each data set, a set of random numbers is generated with the desired standard deviation
and an average of approximately zero. The specified average is then added to each of the noise values.
These values are then multiplied by 0.01 (i.e., 1%) and the Y-value. The result is then added to the Y-
value.

Noise values of this type can be used to approximate measurement errors that are proportional to the
value of the (measured) independent variable, Y.

· N*0.01*YFS: For each data set, a set of random numbers is generated with the desired standard
deviation and an average of approximately zero. The specified average is then added to each of the
noise values. These values are then multiplied by 0.01 (i.e., 1%) and the 'Full Scale Yrange' value. The
result is then added to the Y-value.
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Noise values of this type can be used to approximate instrumental measurement errors that are
proportional to the full-scale range setting typical of most measurement equipment.

The full-scale range setting is determined by rounding the absolute value of Y to the next highest power
of ten.

For example:

for Y-values from 0.0100 to 0.0999 the YFSRange is 0.1,

for Y-values from 0.100 to 0.999 the YFSRange is 1.0 and

for Y-values from 1.00 to 9.99 the YFSRange is 10.

NOTE:
If the Y-values in the data span more than an order of magnitude, this type of
noise is probably the most representative of the actual experimental noise.

Also, when fitting the data it is likely most appropriate to use a weighting factor of
1/Y2.

Std. Dev. of Noise (NSD)

Use the 'Std. Dev. of Noise (NSD)' edit box to set the standard deviation of the random numbers (noise)
that will be added to the dependent, Y, variable values. These values also will be placed in the 'SigmaY'
data column, that is, the last data column.

Average Noise Value

Use the 'Average noise value' check and edit boxes if you want the average of the added noise values to
differ from (approximately) zero.

Limit Y-Values

Select (check) the 'Limit Y-Values' check box if you want FitAll to limit (constrain) the generated Y-values
to the range Min <= Y <= Max.

· Min: Use the 'Min' edit box to enter the minimum Y-value that will be generated. If a generated Y-value
is less than the specified Min. value, FitAll will adjust the added noise value so that the resulting Y-value
is equal to the specified Min value.

· Max: Use the 'Max' edit box to enter the maximum Y-value that will be generated. If a generated Y-
value is greater than the specified Max. value, FitAll will adjust the added noise value so that the
resulting Y-value is equal to the specified Max. value.
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CAUTION:

If any of the Y-values are adjusted, the statistics and validity of any subsequent
Monte Carlo analysis will be very questionable!

This option has been provided to allow you to simulate how an instrument's
response may affect the results. -- If the monitoring instrument's range is
exceeded, it may report a limiting value.

This option may be useful in investigating how instrumental (or measurement)
range limitations affect (and potentially distort) the analysis results.

Exercise extreme caution when using this option.

Monte Carlo

Data Directory

Click the 'Data Directory' button to select the directory (folder) in which the data files are to be saved. The
Browse For Folder dialog that appears looks like this:

 

Base file name

Use the 'Base file name for data sets' edit box to enter a base file name for the generated data files. FitAll
will create file names based on this name by adding an additional five characters to the name.

For example, if the entered name is 'ABCD', FitAll will created a series of files named
ABCD0000001.DTA, ABCD0000002.DTA, etc. each containing one set of generated data.
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NOTE:
A special file named ABCD00000.DTA also will be created. This data file contains
the parameter values that were used to generate the data and has the same
format as the results data file that is created when Monte Carlo analyses are
done.

Generate Files with Numbers

Use the From spin-edit box to enter the number of the first data set that FitAll should generate. The
maximum value is 2,000,000.

Use the To spin-edit box to enter the number of the last data set that FitAll should generate. The
maximum value is 2,000,000 and must be greater than or equal to the first file number.
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Generate Multi-Fit Configs...
Choose Edit > Generate Multi-Fit Configs to create a file containing a set of function configurations
(variations) that can be used to analyze one set of data with many different forms (variations) of the basic
function.

When you select Edit > Generate Multi-Fit Configs, the 'Generate Multi-Fit Configurations' dialog box
appears. It looks like this:

and has three tabs -- Function , Constants  and Parameters .

Click on each of the tabs in turn and change the settings to what you want, then click the OK button.

70 71 72
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Function

Ftn Category

Use the Ftn Category drop down list to restrict (limit) the list of selectable functions.

NOTE:
Only the functions in the category that you select will be displayed in the Function
drop down list.

Function

Use the Function drop down list to select the function that you want to use to generate the multi-fit
configurations.

If more than one variation of the function is available, one or more dialog boxes requesting additional
information will appear. In each dialog, enter a value that corresponds to the function variation that has the
largest number of parameters and click the OK button.

Help for Current Function, 

Click the  button to display Help for the currently selected function.

Config. file name

Click the 'Config. file name' button to select / create a file that will contain the generated configuration
information. The file name extension 'fmc' stands for FitAll Multi-fit Configuration file.

Generate Configuration Numbers

Enter the number of the first configuration that you want saved to (or appended to) the configuration file in
the From spin-edit.

In most cases, the value should be 1 (one).

However, if the function being used has a very large number of variations, it is possible that you may have
stopped the configuration generation process before it had generated all possible configurations. In such a
case, you may want to start generating additional configurations at the point following those that have
already been generated and append the these configurations to the existing configuration file.
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Enter the number of the last configuration that you want saved to (or appended to) the configuration file in
the To spin-edit.

Click the Reset button to reset the first and last configuration numbers to 1 and the maximum number of
configurations can be generated for the current settings.

Constants

Name

Initially, the names displayed in the 'Name' column are the current default constant names for the selected
function. You can change the names to whatever you want.

Value

Initially, the values displayed in the 'Value' column are the current constant values for the selected
function. You can change the values to whatever you want.

FitAll, in its current implementation, changes the values of the constants when it generates the different
'Multi-Fit Configurations'.

NOTE:
Only a very small number of FitAll's functions are 'Multi-Fit enabled'.
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Parameters

Name

Initially, the names displayed in the 'Name' column are the current default parameter names for the
selected function. You can change the names to whatever you want.

Value

Initially, the values displayed in the 'Value' column are the current parameter values for the selected
function. You can change the values to whatever you want. For non-linear functions the parameter values
that you enter will be used as the initial estimates when the fit is done.

NOTE:
The 'Value' column is not displayed when the selected function is linear in its
parameter as initial parameter estimates are not required for a lls analysis.
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Generate Report

Click the Edit > Generate Report... menu selections or click the  button to create a MS Word or Excel
report (document) that contains the results of your analysis.

Each report can contain the contents of any or all of FitAll's windows.

When you choose Edit > Generate Report... the 'Generate Report' dialog box appears. It looks like this:

Report Contents

Select (check) the report elements that you want to include in the report.

Report Type

Select (click) on of the MS Word or LO Writer radio buttons to choose the type of report that you want
FitAll to create.
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Order Report Contents

Select (click to highlight) one of the items in the 'Report Contents' check list and click the 'Move Up' and
'Move Down' buttons to change the order of the report's contents.

NOTE:
Only those items in the 'Report Contents' check list that are checked will appear
in the report.

Append to Existing Report

Select (check) the 'Append to Existing Report' check box if you want the generated report appended
(added) to an existing open document.

NOTE:
The report will be added to the end of the open and active document. It will NOT
be inserted at the cursor position.

This can be very useful when you are writing a report at the same time that you
are analyzing your data or are otherwise documenting the fits as you do them.

Heading Style Level

Each element in the report has a heading, such as 'Data', Data Graph', 'Fit' or 'Fit Graph'.

In MS Word and LO Writer the headings are formatted with a 'heading style', such as 'Heading 1' or
'Heading 2'.

The 'Heading Style Level', which can have values from 0 to 9, applies the standard Heading Style (1 to 9)
to the heading text. A value of 0 means that the 'Normal' style will be applied to the heading text.

Select All

Click the 'Select All' button to include all possible results and information in the report.

Unselect All

Click the 'Unselect All' button to remove all possible results and information in the report so that you can
more easily select the one or two items that you actually want in the report.

Restore defaults

Click the 'Restore defaults' button to change the report settings to FitAll's standard (default) settings.Enter
topic text here.
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Scripted Ftns...
Scripted functions are functions that can be defined by a one line expression 

When you select Edit > Scripted Ftns..., the 'Edit Scripted Functions' dialog box appears. It looks like this:

Function Number:

Use this spin-edit to select the function number, from 101 to 200, that is to be created or edited.
(Note: The Evaluation Edition is limited to function numbers 101 to 103.)

NOTE:
Changing the function number after making changes to a function definition does
NOT save the changes.
You MUST click the "Save Changes" button to save the changes that you have
made.

Delete this Ftn:

Click this button to delete / remove the current function definition.



- 76 -

Reference GuideEdit, Scripted Ftns...

Expression: Y=

Enter the expression for the right hand side of the equation, Y = f(X, Pn), in which X is the independent
variable and the Pn's are the parameters to be resolved
For example: P1 + P2*X is the expression for a straight line that has an intercept of P1 and a slope of P2.

Expression Elements (Select to insert):

Use this drop down combobox to choose an expression element to insert into the Expression edit at the
cursor or simply to view the list of elements that can be entered into the Expression edit.

Valid Expression Definition Elements and Operations

Element  Description

X The independent variable.

P1, .., P10 The parameters to be resolved, starting with P1.

 + Addition operator.

 - Subtraction operator.

 * Multiplication operator.

 / Division operator.

 ( ) Parentheses to group operations.

Abs(V) The result is the absolute value of  V.

ArcCos(V) The result is the ArcCosine in radians of the value, V.

ArcSin(V) The result is the ArcSine in radians of the value, V.

ArcTan(V) The result is the ArcTangent in radians of the value, V.

BpwrP(V1, V2) The result is the absolute value of V1 raised to the power V2; that is,

.
Note: This is the same as Power(V1,V2).

Cos(V) The result is the Cosine of the value V radians.

Exp(V) The result is e raised to the power V; that is, 

Exp10(V) The result is 10 raised to the power V; that is, 
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Element  Description

Frac(V) The result is the fractional part of V.
For example Frac(1.234) is 0.234.

Int(V) The result is the integer part of V.
For example Int(1.234) is 1.

IntPower(V1, V2) The result is the value of V1 raised to the integer power V2; that is, 
.

Ln(V) The result is the natural logarithm of the absolute value of V; that is, Ln|V|
.

Log(V) The result is the base 10 logarithm of the absolute value of V; that is, Log|
V|.

Pi The constant π , which is equal to 3.14159265358979.

Power(V1, V2) The result is the absolute value of V1 raised to the power V2; that is,

.

Round(V) The result is the integer result of rounding V.
For example, Round(10.4) is 10 and Round(10.6) is 11.

Sin(V) The result is the sine of V radians.

Sqr(V) The result is the square of V; that is 

Sqrt(V) The result is the square root of V; that is, 

Trunc(V) The result is the integer result of truncating V.
For example, Trunc(10.4) is 10 and Trunc(10.6) is 10.

Description:

This description added here appears in the function drop down list used in the setup the analysis
dialog.

Categories:

This semi-colon, ";", delimited list of categories used to filter the list of functions that appear in the drop
down list used in the setup the analysis  dialog.

Nbr of Parameters:

Number of parameters contained in the function's expression and will be resolved by the regression
analysis.

92
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Ftn is linear in its parameters:

Select, check, this checkbox if the function expression is linear in its parameters, P; that is, it is of the

general form  

Default X-Value:

The value of the independent variable, X, that is used when testing the function.

Parameter

The parameters that are to be used in the expression. Which parameters are available is set using the
"Nbr of Parameters" spin-edit.

Name:

Descriptive names of the parameters.

Default Value:

The default values of the parameters that are used when testing the correctness of the function.

Test using default values:

Click this button to evaluate the function using the default values the parameters, P, and the independent
variable, X.

Save Changes Button:

Click this button to save the changes.

Copy and Save As Ftn#:

Use this button and the accompanying spin-edit to copy and save the current function definition with a
different function number.
This is a convenient way to create a new function definition that is similar to the current definition.
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Properties...
Text Window

Graph Window
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Text Window

Most text windows contain a grid in which columns of numbers are displayed. The Properties dialog for
text windows looks like this:

Column Number

Use this spin edit to select a column.

Col. Number Format

Use this drop down edit to view and change the number format of the selected column.

Reset All to Default Num Fmt

Click this button to set the numeric format for all columns in the active window to the default numeric
format.

NOTE:
The default numeric format can be changed by choosing the Options >
Preferences  menu selection and changing the value of 'Default Number
Format' on the 'General' tab.

Set All to Selected Nbr Fmt

Click this button to set the number format for all columns in the active window to the current column's
numeric format.

126



- 81 -

Reference Guide Edit, Properties...

Graph Window

The Properties dialog for windows that contain a graph looks like this:

The dialog contains a least four tabs on which are general settings, bottom and left axis settings and one
tab with settings for each data series. Only the 'sensitivities graph' displays more than one data series.

Only those properties that apply to the current graph are visible and changeable. For example, the 'fit
graph' can have a legend, but the 'data graph' can not.

In most cases, changing a property will be immediately reflected in the graph. That is, you do not have to
close the Properties dialog box to see the changes.
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General

Title

Use the edit box to change the title text.

Visible

Use this check box to determine whether the title is displayed on the graph.

Reset

By default, the title is the same as the data set's title. If you wish to change it, un-check this setting and
then edit the title text.

Sub-Title

Use the edit box to change the sub-title text.

Visible

Use this check box to determine whether the sub-title is displayed on the graph.

Reset to Default

By default, the sub-title is the same as the data set's sub-title. If you wish to change it, un-check this
setting and then edit the sub-title text.
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Fonts

Click one of the buttons in the Fonts group to view and change the font that is used for the Title, Sub-
Title, Axis labels, Axis numbers and Legend text.

Bckgrd Colors

Click the small button to the left of the 'Outside' label to change the background color around the outside
of the graph; that is, the part of the graph on which the title, sub-title and Axis labels are displayed.

Click the small button to the left of the 'Inside' label to change the background color on the inside of the
graph; that is, the part of the graph on which the data points and legend are displayed.

Border Styles

Use the 'Outside' and 'Inside' drop down lists to choose a border style.

For example, choosing an outside border style of 'Solid3' will draw a thick line around the entire graph.

Legend

Check the Visible check box to make the legend visible.

Select the Location radio button that corresponds to relative position where you want the legend to
appear.

Use the Number Fmt drop down list to select the format to be used when displaying numbers in the
legend. At present, only the 'fit graph' has numbers in its legend.

Select the small button to the left of the Bckgrd Color label to change the legend's background color.
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Axis

Values to Plot on this axis

By default, FitAll plots the X-values, the independent variable, on the bottom axis and the Y-values, the
dependent variable, on the left axis.

You can change this by selecting either the X or Y radio button.

NOTE:
If you select the Y radio button in the Bottom Axis tab, FitAll will automatically
select the X radio button in the Left Axis tab.

That is, FitAll always will plot the X vs. Y values -- this option simply determines
whether the X-values are plotted on the bottom or left axis.

In most cases, it is appropriate to plot the X-values along the bottom axis. However, there can be
situations in which it is desirable to change this.

For example, in the solar cell functions, function numbers 0504 to 0507, the dependent variable, Y, is the
voltage and the independent variable, X, is the current. However, in solar cell, electrochemistry and other
related fields it is traditional to plot the current, X in these cases, on the left axis and the voltage, Y, on the
bottom axis.
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Axis Caption

Use the edit box to change the axis caption's text.

Visible

Use this check box to determine whether the axis caption is displayed on the graph.

Reset to Default

By default, the axis caption is the same as the data set's axis title. If you wish to change it, un-check this
setting and then edit the axis caption text.

Scale Style

Use the Reversed check box to change how the values are plotted. Normally FitAll makes plots  the
smallest values at the lower left corner of the graph. If the Reversed check box is checked, the largest
value for the axis in question will be plotted at the lower left corner of the graph.

Select the Linear radio button to have axis use a linear scale.

Select the Log radio button to have the axis use a logarithmic scale.

Scale Factor

Use the Value edit box to enter the number by which the axis values will be divided. The result will be that
the numeric axis labels will be scaled by the value amount.

For example, if the original numeric labels on the axis were 0.00, 500.00 and 1000.00 and a scaling factor
value of 100 was entered, the new numeric axis labels would be 0.00, 5.00 and 10.00. Also, the axis label
will be "original axis label / 100"

Use the Format drop down list to set the format of the divisor displayed in the axis label.

Limits

Check the AutoScale checkbox if you want FitAll to automatically determine the axis limits and the
number of "tic marks".

If you want to set the axis limits yourself, uncheck the AutoScale check box and enter the minimum and
maximum axis values in the Min and Max edit boxes.

Ticks

When the Visible checkbox is checked, the tic marks are displayed on the graph.

The # of tick marks spin edit determines the number of tic marks that will appear. The minimum value is
two.

Check the Labels visible checkbox if you want the numeric values displayed next to the tic marks.

Use the Label Fmt drop down list to set the format of the numbers that are displayed next to each tic
mark.
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Grid Lines

When the Visible checkbox is checked, the grid lines are displayed on the graph.

Use the Width spin edit to set the thickness of the grid lines.

Click the small button to the left of the Color label to choose the grid line color.

Data Series

OR
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The properties available on the Data Series tab depend on the type of graph that is being displayed. For
example, the 'Fit Curve' and 'Confidence Band' groups of properties are only available for the 'fit graph'
window.

Visible

When the Visible checkbox is checked, the data series is displayed on the graph.

Data Columns

Use the Data Columns drop down list to select the data column that will be plotted on the X- or Y-axis.
For example, you may want to plot the "point number" rather than the actual value along one of the axes.

Points

When the Visible checkbox is checked, the data points are displayed on the graph.

Use the Size spin edit to set the size of the data points.

Click the small button to the left of the Color label to choose the data point's color.

Click the small button to the left of the Border Color label to choose the color of the data point's border
(outline).

Error Bars

When the Visible checkbox is checked, the error bars are displayed on the graph.

Click the small button to the left of the Color label to choose the error bar's color.
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Point Connectors

When the Visible checkbox is checked, the connector lines between data points are displayed on the
graph.

Use the drop down list to select the type of connector lines that you want to be drawn between the data
points.

Use the Width spin edit to set the thickness of the connector lines.

Click the small button to the left of the Color label to choose the color of the point connectors.

Fit Curve

NOTE:
The fit curve is only displayed in the fit graph window.

When the Visible checkbox is checked, the calculated fit curve through data points is displayed on the
graph.

Use the # Pts spin edit to set the number of calculated points that will be used to draw the "smooth" curve
through the actual data points. The higher the number, the "smoother" the calculated curve; however, the
higher the number, the longer it will take to draw the graph.

Use the Width spin edit to set the thickness of the fit curve.

Click the small button to the left of the Color label to choose the color of the point connectors.

Confidence Band

NOTE:
The confidence lines are only displayed in the fit graph window.

When the Visible checkbox is checked, the confidence band lines are displayed on the graph.

Use the % drop down list to select the percent confidence that you want the confidence lines to illustrate.

You can choose confidence curves that corresponds to the 50% (CM=0.67), 67% (CM=1), 95%
(CM=1.96) or 99% (CM=2.58) confidence interval. Two additional lines are drawn using the formulas:

and

When evaluating the goodness of fit:
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· The standard deviation of the parameters indicates how well determined or significant each of the
resolved parameters is.

· Tends in the residuals graph can help you determine the appropriateness of a particular function or
identify data collection biases (determinant errors).

· Plotting the confidence band can assist you in visualizing the fit quality. The 50% confidence band (that
is, when the 'confidence multiplier', CM, is equal to 0.67) is often called the 'Probable Error'.

· A confidence band of 67% indicates that there is a 67% probability that the 'true' value of the function is
within that band.

· A 'sensitivities graph' can help you visually determine the data range over which the calculated
function's value is most influenced by each parameter.

Use the Width spin edit to set the thickness of the confidence band lines.

Click the small button to the left of the Color label to choose the color of the confidence band lines.
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Analyze
Setup...

Analyze

One point...
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Setup...

Choose Analyze > Setup, press Alt+S or click the  button to setup the data analysis.

When you select Analyze > Setup the 'Analyze Set Up' dialog appears. It looks like this:

NOTE:
Not all of the tabs will be visible.

Which tabs are visible is determined by the current function and the analysis
settings.

For example, if the current function does not have any constants, the 'Constants'
tab will not be visible.
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Function

 Function Category

Use the Ftn Category drop down list to restrict (limit) the list of selectable functions.

NOTE:
Only the functions in the category that you select will be displayed in the Function
drop down list.

HINT:
If you typically use a small number of the available functions you can add
categories of your own so that only those functions are displayed in the Function
drop down list.

See Options > Preferences > Ftn categories  to see how to add categories of
your own.

Function

Use the Function drop down list to select the function that you want to use to analyze the current data set.

If more than one variation of the function is available, one or more dialog boxes requesting additional
information may appear. In each dialog, enter an appropriate value and click the OK button.

134
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NOTE:
The dialog boxes requesting additional information are only displayed when the
function is initially selected. If you want to see or change the settings you've
made, expand the Function drop-down list and click on the same function.

Help for Current Function, 

Click the  button to display Help for the currently selected function.

Analysis Range

Use the First Point and Last Point spin edits to set the range of data points that you want to be used in
the regression analysis,

Limit parameter values

Check this item if you want to limit the value of one or more of the parameters' values to a specific range
of values.

When FitAll analyzes a set of data, it adjusts the value of each parameter after each iteration. For some
functions, more than one solution may be possible and FitAll may assign an unrealistic value to one or
more of the parameters. To prevent this from happening, you can assign upper and lower limits to a
parameter's value. When you do this, FitAll will ensure that the parameter's value is limited to the range
you specify.

NOTE:
When you select a function from the Function drop down list most functions that
are likely to require parameter limits will automatically check this item.

When checked, the Analyze > Setup > Parameters  tab will include columns in which you can enter the
maximum and minimum parameter values and will look like this:

99
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Force automatic initial estimates

This check box tells FitAll to re-evaluate its estimates of the parameter values before every analysis.

Check this option if you are analyzing several sets of data with the same function and you know that:

· The parameter values resulting from the regression analysis will have widely different values.

· FitAll makes sufficiently good initial estimates.

· Do not check this option if you want to use the results of the previous analysis as the starting point for
the analysis you are about to do.

NOTE:
To manually instruct FitAll to generate initial parameter estimates:

· Select (Click) the 'Parameters' tab.

· Click the 'Initial Estimates' button.

Use analytical partial derivatives

This check box should be checked.

When FitAll is fitting a set of data, it adjusts the value of each parameter after each iteration. To
determine how large the adjustment should be, it must calculate the partial derivatives of the function with
respect to each of the parameters. FitAll always does this calculation numerically and then updates these
values using an analytical expression for the required partial derivative when the required analytical
expression is available.

If this item is not checked, FitAll will not update the numerically calculated values.
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In most cases, the solution arrived at will be the same, whether or not this item is checked.

This option is primarily for the use of those who have the Research Edition and are creating user defined
FitAll Function Libraries (ffl's) of their own.

Generate Report after each fit

When checked FitAll will generate an Excel or Word report whenever it successfully fits a set of data.

The type of report and its contents can be set by selecting Preferences, Report .

NOTE:
When doing Batch Mode, Monte Carlo or Multi-Fit Analyses a large number of
reports may be created -- This can be very time consuming.

Weighting Factor

Use this drop down list to select one of the five available weighting schemes.

The weighting factors that can be selected are: 1/(SigmaY)2, 1, 1/Y, 1/(0.1*Y)2 and 1/(0.01*Y)2.

Weighting
Factor Comment

1/(SigmaY)2 The weighting factor used is proportional to the reciprocal of the
square of the Y-values' standard deviation.

1 All data points are equally weighted.

That is, all measured values of the function are assumed to be of
equal precision.

Use this weighting scheme unless you know that the errors
associated with the data are different.

1/Y The weighting factor used is proportional to the inverse of the value
of the function.

Use this weighting scheme when the data is distributed around
each point according to a Poisson distribution rather than a
Gaussian distribution as is assumed to be the case in the least-
squares method.

A Poisson distribution assumes that (SigmaY)2 is directly
proportional to the value of Y.

Poisson distributions are normally encountered in counting
experiments; that is, in situations in which the magnitude of the
measured value of the function is determined by summing
(counting) the number of times that a particular event occurs.

1/(0.01*Y)2 This weighting factor assumes that the standard deviation,
SigmaY[i], of the function is equal to 1% of the function's measured
value.

135
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Weighting
Factor Comment

1/(0.01*FSS)2 This weighting factor assumes that the standard deviation,
SigmaY[i], of the function is equal to 1% of the measurement
instrument's Full-Scale Setting, FSS, that was required to measure
the function's value.

This weighting scheme is intended to reflect the measurement
errors that are usual with most common measurement instruments,
such as (auto-ranging) voltmeters.

For example:
for Y-values from 0.0100 to 0.0999 the FSS is 0.1, and
for Y-values from 1.00 to 9.99 the FSS is 10.

Termination Criterion

FitAll alters its estimate of the parameter values at each iteration so that successive values of the
reduced chi-square statistic becomes smaller.

The termination criterion is used to determine when the difference between the calculated curve and the
actual data points is small enough to assume that the final (correct) values of the parameters have been
determined.

The actual convergence test used is: Dc/c2 <= Termination criterion.

If the termination criterion's value is large, for example 0.1, relatively few iterations will be required in order
to get a fit. However, the accuracy and precision of the calculated parameters may be low.

If the termination criterion's value is small, for example 10-15, a relatively large number of iterations may be
required before FitAll converges to the final parameter values. The final values, however, generally will be
more precise than if a large value of the termination criterion had been used.

If the termination criterion's value is too small, numeric truncation errors may prevent convergence from
ever occurring.

The termination criterion's default value of 0.001 is appropriate for a wide range of fitting functions and
data sets.

Max. Iterations

FitAll uses an iterative process to locate the best-fit parameter values. That is, it starts with initial guesses
and, by repeating the calculations (iterating), it refines these values until the difference between the
calculated values and the actual values is at a minimum.

If the initial guesses are too far from the final values or if the data are not well dispersed over an
appropriate range, the number of iterations required can be very large. In such circumstances, it may take
a long time to obtain the final results.

The 'Max. iterations' value tells FitAll to stop after that number of iterations, even if a best-fit has not been
obtained. You will then be given the option of terminating or continuing with the analysis.
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CAUTION:
The final results reported by FitAll do not indicate whether the analysis was
stopped before the termination criterion was met!

Analysis Method

FitAll can analyze your data using one of three methods.

Select (click) the radio button corresponding to the analysis method that you want to use when fitting your
data (See: Theory Behind FitAll ).

For functions that are non-linear in their parameters, either the non-linear least-squares, nlls , or non-
linear absolute deviations, nllad , methods can be used.

For functions that are linear in their parameters the linear least-squares, lls , method will be used.

Analysis Type

Select (click) the radio button that corresponds to the analysis type that you want to use.

· Normal: Choose this analysis type to do one analysis using the current function and settings. This is the
most commonly used analysis type.

· Monte Carlo: Choose this analysis type to analyze multiple data sets with the same function and initial
settings (See: Edit > Generate Monte Carlo data sets  and Analyze > Setup Monte Carlo ).

When checked, the Monte Carlo  tab is enabled (visible) and allows you to enter the additional
information required by FitAll to analyze multiple data sets.

· Multi-Fit: Choose this analysis type to analyze one set of data with many different initial settings; that is,
with different variations of the same function (See: Edit > Generate Multi-Fit Configs... ).

Only some of the functions in FitAll are "Multi-Fit enabled" (See: Analyze > Multi-Fit ).

When checked, the Multi-Fit tab is visible and allows you to enter the additional information required by
FitAll to do multiple analyses of the same data set.
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Reference GuideAnalyze, Setup...

Constants

The 'Constants' tab in the 'Analyze Set Up' dialog allows you to change the names and values of the
current function's constants.

To edit or change a name or value, select the value you want to change by clicking on the cell and (a)
entering the new value or (b) press the F2 key and edit the existing value.
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Parameters

The 'Parameters' tab in the 'Analyze Set Up' dialog allows you to change the names and values of the
current function's parameters.

To edit or change a name or value, select the value you want to change by clicking on the cell and (a)
entering the new value or (b) press the F2 key and edit the existing value.

Initial Estimates

To have FitAll automatically calculate the initial estimated values of the parameters, click the 'Initial
Estimates' button.

NOTE:
FitAll can not calculate initial estimates for every function.

If FitAll is unable to calculate the initial estimate, the parameter values will not
change and a message dialog will appear indicating that it was not able to
calculate the initial estimates.

FitAll can not automatically calculated the required initial estimates for any of the
Scripted Functions that you may ceate. (Edit > Scripted Ftns 75
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Monte Carlo

To do a Monte Carlo analysis it is necessary to tell FitAll which data files should be analyzed as well as
the data file in which the results of the analyses should be saved.

Data

FitAll assumes that:

· All of the files to be analyzed have file names that include a five digit number at the end, for example,
'abcd00001.dta'.

· All of the files to be analyzed have the same 'base file name'; for example, abcd.

· All of the files to be analyzed are located in the same directory (folder).

Click the 'First File...' button to select the first file that should be analyzed. The name of this file should
contain the smallest number.

Click the 'Last File...' button to select the last file that should be analyzed. The name of this file should
contain the largest number.

NOTE:
If there are 'gaps' in the numbers, FitAll will automatically go on to the next file.

Check the 'Use All Available Data When Doing the Analyses (Fits)' check box if you are using the
Monte Carlo analysis feature to do batch mode processing  of a number of data files that may not have
the same number of data points. When this selection is checked FitAll will automatically adjust the data
range to include all of the data in each of the data files that it analyzes.
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Results

Click the 'Results file...' button to select or create the data file in to which the results of the analyses will
be saved.

NOTE:
If the file already exists, the results from the current analyses will be appended
(added) to it.

Use the Title edit box to enter the 'title' that will be entered into the results data set.

Use the Sub-Title edit box to enter the 'sub-title' that will be entered into the results data set.
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Multi-Fit

Before doing a Multi-Fit analysis it is necessary to tell FitAll which configuration file should be used as well
as the file into which the results of the analyses should be saved.

MF Function Configurations:

Configuration file:

Click the 'Configuration file...' button to locate the file that contains the multi-fit function configurations that
are to be evaluated.

NOTE:
The configuration file will normally have been created using the menu selections
Edit > Generate Multi-Fit Configs .

Analyze Configuration Numbers:

Use the First and Last spin-edits to identify the function configurations that should be evaluated during
the multi-fit analyses.

Initially, First should be set to 1, one, and Last to a large number so that all of the configurations are
analyzed.

If there are many configurations to evaluate, it may be that not all were initially analyzed; for example,
because of the time required, the analyses may have been stopped before all were completed. Under
such circumstances you can re-start the analyses with a value of First that is one larger than the last one
analyzed and append the results to the same results file.

69
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NOTE:
If the First and Last configuration numbers are equal FitAll will retrieve the
configuration and do the analysis, but it will not append the results to the results
file.

This makes it possible selectively analyze one configuration and view the results
of that particular configuration of the function.

Reset

Click this button to reset the First and Last numbers to the lowest and highest configuration numbers that
are available in the configuration file.

Results:

Results file...:

Click the 'Results file...' button to create the file in which the results of the analyses will be saved.

Title:

Use the 'Title' edit box to enter the title of the results data set.

Sub-Title:

Use the 'Sub-Title' edit box to enter the sub-title of the results data set.



- 104 -

Reference GuideAnalyze, Setup...

Save / Recall Setup

Save setup

Click the 'Save setup' button to save the current analysis setup with the name in the edit box at the top of
the combo box.

If that particular setup already exists, you will be given a chance to cancel the operation.

Recall setup

Click on one of the existing setup names to select it, then click the 'Recall setup' button to retrieve all of
the analysis settings that you previously saved using this name.

Delete setup

If an analysis setup that you previously saved is no longer relevant to your needs, you can delete it by
clicking on its name to select it and then clicking the 'Delete setup' button.
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Analyze

Choose Analyze > Analyze, press Alt+N or click the  button to fit the data; that is, to do the regression
analysis.

This menu item changes depending on the 'Analysis Type' that is selected in the Analyze > Setup,
Function  dialog box.

The following table shows the correspondence between the Analysis Type and the Analyze Menu's text.

Analysis Type Analyze Menu's Text

Normal Analyze

Monte Carlo Analyze Monte Carlo

Multi-Fit Analyze Multi-Fit.
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One point...
Choose Analyze > One point... to evaluate the current function with a particular set of parameters,
constants and independent variables.

When you select Analyze, One point the 'Evaluate function at one point' dialog appears. It looks like this:

If you want to generate a set of data with equally spaced (either linearly or logarithmically) values of the
independent variable(s), X, use the Edit > Generate data set  menu selections.

Value

Enter the values that you want into the appropriate rows of the value's column.

Evaluate

Click the 'Evaluate' button to have FitAll do the calculation and display the result in the 'Result' field.

Reset values

Click the 'Reset values' button to have FitAll reset all values of the parameters, constants and
independent variables.

Print to clipboard

Click the 'Print to clipboard' button to copy all of the text in the 'Evaluate One Point' dialog to the Windows
clipboard. You can then paste the result into another document, such as a MS Word or Excel document,
for future reference.

Close

Click the 'Close' button to return to FitAll.
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View
data graph

fit graph

residuals graph

residuals distribution graph

sensitivities graph

Data

Fit

Residuals

Residuals distribution

Sensitivities

Standard stats

Pearson's R (Linear Corr. Coeff.)

Kendall's tau

Spearman's rank-order

Sum squared diff. of rank
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data graph
Choose View > data graph to see a graph of the data. The graph could look like this:

To change the appearance of the graph, select the menu options Edit > Properties...  or right click in
the graph window and click Properties on the context menu that appears.
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fit graph
Choose View > fit graph to see a graph of the data. The graph could look like this:

To change the appearance of the graph, select the menu options Edit > Properties...  or right click in
the graph window and click Properties on the context menu that appears.

81
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residuals graph
Choose View > residuals graph to see a residuals graph; that is, a graph that displays the difference
between the observed and calculated values of Y vs. X. The graph could look like this:

To change the appearance of the graph, select the menu options Edit > Properties...  or right click in
the graph window and click Properties on the context menu that appears.

The residuals graph plots the difference between the calculated and observed values of the function.

It provides a quick, visual way of determining whether the function used to fit the data is a good or bad
model for the data.

If the function used in the analysis is a good model, the residuals graph will show the points randomly
distributed about the zero line. On the other hand, if the residuals graph shows a trend, the function used
is probably not a good model.

Even when the standard deviations of the fit and of the parameters are quite small, you should investigate
the reasons for trends in the residuals plot. It may be that the function selected is almost a good model,
but needs one or more parameters in it or it may be that some determinant error was introduced during
data collection.
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residuals distribution graph
Choose View > residuals distribution graph to see a residual distribution graph; that is, a graph  that
displays the percentage of data points that are within one or more standard deviations of the best fit. The
graph could look like this:

To change the appearance of the graph, select the menu options Edit > Properties...  or right click in
the graph window and click Properties on the context menu that appears.

The residuals distribution graph plots a histogram of the fraction of data points (as a percentage) versus
their deviations from the best fit line. Each bar in the graph is 1.0 standard deviations wide.

It provides a quick, visual, way of determining whether the residuals (and, therefore, the measurement
errors) are 'normally' distributed. The non-linear least squares (nlls) and linear least squares (lls) methods
assume a 'normal' or Gaussian error distribution, while the non-linear least absolute deviations (nllad)
method does not.
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sensitivities graph
Choose View > sensitivities graph to see a sensitivities graph; that is, a graph that displays  of the
parameter sensitivity of the dependent variable, Y, on each of the parameters vs. X. The graph could look
like this:

To change the appearance of the graph, select the menu options Edit > Properties...  or right click in
the graph window and click Properties on the context menu that appears.

The sensitivities graph plots the 'parameter sensitivity' for each of the function's resolved parameters.

A parameter's sensitivity is given by the relationship:

The 'sensitivities graph' can help you visually determine the data range over which the calculated
function's value is most influenced by each of its parameters.
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Data
Choose View > Data to view and edit the data.

You can only edit and modify your data when the Data window is the active window; that is, when the
cursor is in the Data window. (See: Entering and Editing Data in the Getting Started Guide).

To change the format of the numbers, select the menu options Edit > Properties...  or right-click in the
window and click Properties on the context menu that appears.

80
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Fit
Choose View > Fit to see the results of the analysis in the Fit window.

The Fit window should look like this:

It shows:

· The file name of the data that was analyzed.

· The title of the data set.

· The name of the function that was used in the analysis.

· The analysis method used to do the fit. This can be Non-linear least-squares (nlls), non-linear absolute
deviations (nllad) or linear least squares (lls).

· The range of data points used in the analysis.

· The weighting scheme used.

· The variance or the reduced chi square, c2/n, statistic when non-linear least squares (nlls) and linear
least squares (lls) fitting are used and the average absolute deviation when non-linear least absolute
deviations (nllad) fitting is used.

· The standard deviation of the fit.

· The number of iterations required to obtain the fit.
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· For each of the parameters, its name, its resolved value and its estimated error, which is given as the
standard deviation when the nlls or lls analysis methods are used or as the absolute deviation when the
nllad method is used.

The standard deviation of the fit is calculated as the square root of the variance using the formula:

in which NTerms is the number of parameters resolved and FirstPt to LastPt is the range of data points
used in the analysis.

The standard deviation of each of the resolved parameters is calculated in a similar manner.

The relative standard deviation, RSD /%, or the relative absolute deviation, RAD /%, of the resolved
parameters also will be displayed if the 'Display Rel. Std. Dev. in Fit Window ' option in the Preferences
dialog is checked.

If limiting parameter values were used during the regression analysis, the table also will contain a list of
the parameter limits.

CAUTION:
If one or more of the parameter values is equal to one of its limits, the analysis is
NOT statistically valid.

NOTE:
The values of the lower and upper limits are only displayed if one or more of the
parameter values are outside the ranges defined by the limits.

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.

128

80



- 116 -

Reference GuideView, Residuals

Residuals
Choose View > Residuals to view a table containing the:

· Data.

· Residuals; that is, the difference between the observed and calculated values of the function.

NOTE:
The residuals only are meaningful after an analysis has been completed.

The Residuals window looks like this:

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.
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Residuals distribution
Choose View > Residuals distribution to view a table containing the data that is used to construct the
residuals distribution graph.

NOTE:
The residuals distribution data are meaningful only after an analysis has been
completed.

The 'Residuals distribution' window looks like this:

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.
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Sensitivities
Choose View > Sensitivities to view a table containing the:

· Data.

· Parameter sensitivities, that is, the partial derivative of the function with respect to the parameter
multiplied by the parameter's value.

To see a graph of the parameter sensitivities, choose the View > sensitivities graph  menu selections.

NOTE:
The parameter sensitivities are meaningful only after an analysis has been
completed.

The Sensitivities table looks like this:

To change the format of the numbers, select the menu options Edit, Properties...  or right click in the
window and click Properties on the context menu that appears.
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Standard stats
Choose View > Standard stats to view a table containing some standard statistical values for each of the
current data set's columns, including the:

· Minimum.

· Mean (average).

· Median.

· Maximum.

· Standard deviation.

· Average deviation.

· Skew.

· Kurtosis.

The values are calculated using the data analysis range specified in the Analyze > Setup  dialog.

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.
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Pearson's R (Linear Corr. Coeff.)
Choose View > Pearson's R to view a table containing Pearson's R.

Pearson's is also known as the Linear Correlation Coefficient and provides a measure of the correlation
between two columns of numbers.

The values are calculated using the data analysis range specified in the Analyze > Setup  dialog.

· R is Pearson's R; that is, the linear correlation coefficient. The values of R range from  -1 to +1.

If R = 1, there is a complete positive correlation; that is, the points fall on a perfect straight line with a
positive slope.

If R = -1, there is a complete negative correlation; that is, the points fall on a perfect straight line with a
negative slope.

A value of R near zero indicates that the data are uncorrelated.

· R^2 is the square of R; that is, R * R. Often, R2, rather than R, is reported as the linear correlation
coefficient.

· ProbR is the probability that the absolute value of R should be greater than its calculated value.

Small values of ProbR indicate that the value of R and R2 are likely to be significant.

· Z is obtained using Fisher's z-transformation.

This value can be used to compare the significance of the difference between two measured R-values.

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.
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Kendall's tau
Choose View > Kendall's tau to view a table containing Kendall's Tau, which is a non-parametric statistic
that measures the correlation between two columns of numbers.

The values are calculated using the data analysis range specified in the Analyze > Setup  dialog.

· Tau is Kendall's Tau.

· Ztau is the number of standard deviations from zero.
Small values of Ztau indicate a significant correlation or anti-correlation.

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.
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Spearman's rank-order
Choose View > Spearman's rank-order to view a table containing Spearman's rank-order, which is a non-
parametric statistic that measures the correlation between two columns of numbers.

The values are calculated using the data analysis range specified in the Analyze > Setup  dialog.

· Rs is the Spearman Rank-Order Correlation Coefficient.

· ProbRs is the two-sided significance of Rs' deviation from zero.

Small values of ProbRs indicate a significant correlation or anti-correlation.

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.

93

80



- 123 -

Reference Guide View, Sum squared diff. of rank

Sum squared diff. of rank
Choose View > Sum squared diff. of rank to view a table containing Sum squared differences of rank,
which is a non-parametric statistic that measures the correlation between two columns of numbers.

The values are calculated using the data analysis range specified in the Analyze > Setup  dialog.

· D is the sum-squared difference of ranks.

· ZD is the number of standard deviations by which D deviates from its null-hypothesis expected value.

· ProbD is the two-sided significance level of the deviation of D from its null-hypothesis value.

Small values of ProbD indicate a significant correlation or anti-correlation.

To change the format of the numbers, select the menu options Edit > Properties...  or right click in the
window and click Properties on the context menu that appears.
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Options
Change Font

Preferences
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Change Font

FitAll Default

Click the menu items Options > Change Font > FitAll Default to set the font that FitAll will use to Arial,
Regular, 8 pt.

Font...

Click the menu items Options > Change Font > Font... to set the font that FitAll will use to whatever you
like.

System Default

Click the menu items Options > Change Font > System Default to set the font that FitAll will use to Segoe
UI, Regular, 7 pt.
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Preferences
General

General 2

Ftn categories

Report

General

Max. data points

Use this spin-edit box to enter the maximum number of data points in a data set.

The amount of memory installed in your computer may restrict the maximum value to a number less than
FitAll's upper limit of 65,536.

NOTE:
If the Max. data points or Max. data columns is changed the current data set will
be removed from the computer's memory and all windows will be closed.
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Max. data columns

Use this spin-edit box to set the maximum number of data columns in a data set.

The amount of memory installed in your computer may restrict the maximum value to a number less than
FitAll's upper limit of 64.

NOTE:
If the Max. data points or Max. data columns is changed the current data set will
be removed from the computer's memory and all windows will be closed.

Max. iterations

Use this spin-edit box to set the maximum number of iterations that will be used to analyze a function.

NOTE:
The Max. iterations setting also can be changed in the Analyze,Setup  dialog.

FitAll uses an iterative process to locate the best-fit parameter values. That is, it starts with initial guesses
and, by repeating the calculations (iterating), it refines these values until the difference between the
calculated values and the actual values is at a minimum.

If the initial guesses are too far from the final values or if the data are not well dispersed over an
appropriate range, the number of iterations required can be very large. In such circumstances, it may take
a long time to obtain the final results.

The 'Maximum iterations' value tells FitAll to stop after that number of iterations, even if a best-fit has not
been obtained. You will then be given the option of terminating or continuing with the analysis.

CAUTION:
The final results reported by FitAll do not indicate whether the analysis was
stopped before the termination criterion was met.

Max. circ. ftn. iterations

Use this spin-edit box to set the maximum number of iterations that will be used to evaluate a 'circularly
defined' (implicit) function.

Implicit (circularly defined) functions are functions in which the function's value depends on its own
magnitude; that is, the function, Y, is defined as Y = f(X, Y) rather than the more common Y = f(x).

Functions 0416, 0501 to 0503 and 0505 to 0507 are examples of implicit functions. FitAll uses an iterative
(successive approximation) method to evaluate functions of this type. The value of 'Circ. ftn. max.
iterations' constant is the maximum number of iterations that FitAll will use in evaluating the function.

The default value of 50 is adequate in the vast majority of cases. Increase this value if it seems that the
function evaluations are not correct.

Default Number Fmt

Use this drop-down list to select the default format that FitAll should use when displaying numeric values.
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Set New SigmaY's to 1.0

Select this check box if you want FitAll to assign a value of 1.0 rather than zero to SigmaY when you add
a new data point (see: Edit, Add point ).

NOTE:
This setting also affects how data is entered when pasted from the Windows
Clipboard into the data window.

If the number of columns of data in the text that is being pasted into the data
window is less than the number of data columns in the current data set the extra
data columns will be assigned a value of one if the 'Set New SigmaY's to 1.0' is
checked, otherwise a value of zero will be assigned to the extra data columns.

Display All Data in Graphs

By default, FitAll displays the data points that were used in the regression analysis in the Fit, Residuals,
Residuals Distribution and Sensitivity graphs.

Check this option to have all of the data points displayed, even if some of them were not used in the
regression analysis.

This can be useful for getting a visual feeling of how important the "missing" data points are to the analysis
or if they deviate significantly from the fitted curve when they are not included when doing the fit.

NOTE:
The Data graph always displays all of the data points.

Display Rel. Std. Dev. in Fit Window

Check this option to have the Fit Window display an extra column that contains the relative standard
deviation, RSD /%, or the relative absolute deviation, RAD /%.

Open Last Used Data File On Startup

Select this check box if you want FitAll to open the last used data file when it starts-up.

Allow Multiple Instances

Select this check box if you want to run more than one copy (instance) of FitAll at a time.

· When this option is checked, double clicking on the FitAll icon will start up a new copy of FitAll, even if
one is already running.

· When this option is not checked, double clicking on the FitAll icon will start the first copy of FitAll or
switch to a currently running copy of FitAll, if one is active.

NOTE:
To do a 'side-by-side' comparison of the fit of two different functions to the same
data, run two instances of FitAll and analyze the same data with a different
function in each instance.

35
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Check Data Sorted Before Estimates

Select this check box if you want FitAll to check whether the data has been sorted before it makes its
initial estimates.

When FitAll makes its Initial Parameter Estimates it normally expects the data to be sorted on the first
data column. If the data is not sorted, the initial estimates  may not be appropriate.

Copy Data As Displayed

Select this check box if you want FitAll to copy its data to the Clipboard as it is displayed in the data
window/tab. If not checked, the data will be copied using as many significant digits as are required and in
a format that minimizes the number of characters in the number.

Font

Click this button to choose the font that FitAll will use to display information in its text windows, such as
the data, fit, residuals and info windows.

Display Status / Cancel Dialog

· Sorting data: Check this item if you want to be able to cancel a data sort operation before it is
completed.

· Fitting data to a function: Check this item if you want to be able to cancel the fitting operation before it
is completed.

· Generating a report: Check this item if you want to be able to cancel the report generation operation
before it is completed.

· Generating Monte Carlo data sets: Check this item if you want to be able to cancel the generate
Monte Carlo data sets operation before it is completed.

· Monte Carlo (batch mode) analyzing: Check this item if you want to be able to cancel the Monte Carlo
analysis operation before it is completed.

· Generating Multi-Fit configurations: Check this item if you want to be able to cancel the Multi-Fit
configuration generation before it is completed.

· Multi-Fit analyzing: Check this item if you want to be able to cancel the Multi-Fit analyzing operation
before it is completed.

Recent files menu items

· Display: Check this item if you want the names of recently used data files listed in the File menu.

· As submenu: Check this item if you want the list of recently used data files to appear as a sub-menu
item under the main File menu. When this is not checked, the names of the recently used data files are
displayed directly on the File menu.

· Separator Above: Check this item if you want a separator bar above the first listed file or the sub-
menu.

· Separator Below: Check this item if you want a separator bar below the last listed file or the sub-menu.
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· Max. items: Use this spin-edit box to set the number of recently used files you want to appear in the
recently used file list under the File menu item.

General 2

Use Alternate Row Colors in Grids

Check this item if you want alternate rows in most grids to have a different color.

Click on the Alternate Row Color 1 and 2 color boxes to change the colors that will be used.

Auto. Adjust Col. Widths

FitAll normally adjusts the widths of columns whenever a window that contains a table is displayed.

With large data sets, for example of 10,000 data points or more, the display of the window can be rather
slow.

Use this setting to indicate when FitAll should or should not automatically adjust the column widths in a
table.
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Delete Selected Rows On Paste

When checked and pasting rows of data into the Data window any selected rows will be deleted before the
new data is pasted into the window.

Allow Unselected Row Delete

When editing the data allow the Ctrl + Del key or the to delete the row even when the entire row is not
selected.

Return / Enter Appends Data Row

Select this check box if you want FitAll to automatically append a row in the data window when the cursor
is in the last row and column. This can speed up entering data into the data window.

Apply Graph Properties Immediately

When changing the properties  of a graph FitAll normally applies each change to the current graph as
the property is changed.

With large data sets, for example of 100,000 data points or more, some of the property changes may be
somewhat time consuming.

Uncheck this check box to have FitAll delay applying the changes until the Properties dialog box is
closed.

Always Redraw Graphs

When FitAll displays a graph window it normally recalculates and redraws the graph.

With large data sets, for example of 100,000 data points or more, this may be somewhat time consuming.

Uncheck this check box to have FitAll automatically save the graph as a bitmap and then redisplay the
bitmap rather than recalculating and re-plotting the graph. This will speed up the display of graph windows,
but occasionally the redisplayed graph window may be partially obscured by portions of another window
that was overlapping the graph window.

Display Startup Screen

By default, FitAll displays a startup dialog screen when it starts up.

When FitAll starts it often loads the most recently used data file. If there is a large number of data points
in the file, for example 100,000 or more, this may be time consuming and the startup screen will show that
FitAll is actually starting up and loading data.

If you do not want the startup screen to appear, uncheck this checkbox.

Display status line

Select this check box if you want FitAll to display a status line at the bottom of its 'desktop'.

Display Tabs on Multiple Lines
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Select this check box if you want FitAll to display the window tabs on multiple lines when there are more
tabs than can be displayed in a single row and still have all of the tabs visible. If this is not checked scroll
buttons will appear so that the tabs can be scrolled in and out of view.

For example, the row of tabs could look like this:

or this:

Display Tabs at Top

Select this check box if you want FitAll to display the tabs with the Window names at the top. If not
checked, the tabs will be displayed at the bottom of the main window.

Display Image on Tabs

Select this check box if you want FitAll to display a small image on the tabs to indicate whether the tab
contains a window that contains a graph or text.

Check for Updates at Startup

FitAll automatically checks MTR Software's website for updates once every 30 days.

To change how often FitAll automatically checks for updates, use the "Days" spin-edit. 

If you do not want FitAll to automatically check for updates uncheck this checkbox.

NOTE:
At any time, you can check for updates by making the menu selections Help >
Check for Updates..  or by using the Windows menu selections Start >
Programs > FitAll80 > Check for Updates.
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Ftn categories

Function

 Use this drop down list box to select the function whose categories you want to view or change.

Help for Current Function, 

Click the  button to display Help for the currently selected function.

All Categories

The 'All Categories List Box' lists all of the function categories that have been defined and have been
assigned to at least one of the available functions.

Add

Click this button to add the category highlighted in the 'All Categories' list to the 'Function Categories' list
for the current function.
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Function Categories

The 'Function Categories List Box' list the categories associated with the currently selected function.

New Ftn Category 

Enter a new category into this edit box.

When you are sure that you actually want to add the new category, click the 'Add New Category' button. It
will be added to the current Function Categories list and to the All Categories lists.

NOTE:
The list of function categories is sorted alphabetically.
If you name your new category something like "* My Favourite Ftns" it will appear
at the top of the list.

Add New Category

Click the 'Add New Category' button to add the category in the 'New Ftn category' edit box to the current
function.

Remove Category 

Click this button to remove the category that is highlighted in the 'function's categories' list.

Reset Ftn Categories 

Click this button to reset the current function's categories to its default values.

Reset All Categories

Click this button to reset all of the functions' categories to the default values.
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Report

Report Contents

Select (check) the report elements that you want to include in the report.

Report Type

Select (click) on of the MS Word or LO Writer radio buttons to choose the type of report that you want
FitAll to create.

Order Report Contents

Select (click to highlight) one of the items in the 'Report Contents' check list and click the 'Move Up' and
'Move Down' buttons to change the order of the report's contents.

NOTE:
Only those items in the 'Report Contents' check list that are checked will appear
in the report.



- 136 -

Reference GuideOptions, Preferences

Append to Existing Report

Select (check) the 'Append to Existing Report' check box if you want the generated report appended
(added) to an existing open document.

NOTE:
The report will be added to the end of the open and active document. It will NOT
be inserted at the cursor position.

This can be very useful when you are writing a report at the same time that you
are analyzing your data or are otherwise documenting the fits as you do them.

Heading Style Level

Each element in the report has a heading, such as 'Data', Data Graph', 'Fit' or 'Fit Graph'.

In MS Word and LO Writer the headings are formatted with a 'heading style', such as 'Heading 1' or
'Heading 2'.

The 'Heading Style Level', which can have values from 0 to 9, applies the standard Heading Style (1 to 9)
to the heading text. A value of 0 means that the 'Normal' style will be applied to the heading text.

Select All

Click the 'Select All' button to include all possible results and information in the report.

Unselect All

Click the 'Unselect All' button to remove all possible results and information in the report so that you can
more easily select the one or two items that you actually want in the report.

Restore defaults

Click the 'Restore defaults' button to change the report settings to FitAll's standard (default) settings.Enter
topic text here.

Also See

File, Print to clipboard 20
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Info
Choose Info to open the 'Info' window which looks like this:

This window provides some basic information about the current state of FitAll and your computer,
including:

· The name and location of the current data file.

· Whether the data has been saved since it was last modified.

· The current analysis function.

· The version of FitAll.

· The first six characters of FitAll's serial number.

· The FitAll Function Libraries (FFL's) that are loaded.

· The MS Windows version

· The MS Excel version

· The MS Word version

· The Open Office version
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· The total amount of memory in the computer.

· The computer's CPU speed.
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Help
Contents

Choose Help > Contents to open the FitAll Reference Guide.

The on-line table of contents list other FitAll Guides, such as the FitAll Getting Started Guide and one or
more of FitAll's Function Library guides.

Pressing the F1 key will, in many cases, display a context sensitive help item in the on-line FitAll
Reference Guide.

You also can view the on-line FitAll Reference Guide by selecting the Windows menu items Start >
Programs > FitAll10 > Reference Guide.

Current Function...

Choose Help > Current Function or click the toolbar button, , to open the FitAll Function Guide that
describes the currently selected function.

User Defined Functions...

Choose Help > User Defined Functions... to open a dialog box that provides a list of all the available help
documents that are available for the user defined functions.

This menu item will not be displayed if there are no UDF help documents.

Check for Updates...

Click the menu items Help > Check for Updates to connect to MTR Software's web site to see if an
update is available.

If an update is available you will be given the opportunity to download and install it.

NOTE:

· You also can check for updates by using the Windows menu selections Start,
Programs > FitAll10, Check for Updates.

· You can change when and if FitAll automatically checks for updates by
selecting the menu items Options > Preferences > General 2 > Check for
Updates at startup .

FitAll on the Web...

Click the menu items Help > FitAll on the Web... to automatically start your default web browser and link to
MTR Software's home page. Of course, your computer must have an active connection to the Internet for
this to work.
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email FitAll Support...

Click the menu items Help > email FitAll Support to automatically start your email program with a new
message addressed to support@fitall.com having a subject of FitAll Support and FitAll's version and
serial numbers in the body of the message.

Complete the message with your question or request and send it.

About FitAll

Choose Help > About FitAll to display the 'About FitAll' dialog box. It looks like this:
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How To
Add Scripted Functions

Change Data Column Order

Copy Data From a SpreadSheet  Program to FitAll

Do a Preliminary Analysis

do Batch Mode Analyses

do Monte Carlo Simulation and Analyses

do Multi-Fit Analyses

Sort Data

Spot Data Entry Errors

Verify the Appropriateness of Initial Estimates

Make Calibration Curves

Make Graphs with Total and Sub-Component Curves

Recast a Function
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Add Scripted Functions
To add your own scripted function to FitAll do the following:

1. Decide on the function that you would like to add and write down an expression for it using "X" as the
independent variable and "P1", "P2", etc. as the parameters that are to be resolved.

For example, if you want to fit your data to a straight line the function would be 
Y = P1 + P2 * X
in which P1 is the intercept and P2 is the slope of the line.

Note that the function (a) has two (2) parameters and (b) is "linear" in its parameters.

2. Make the menu selection Edit > Scripted Ftns.... The "Edit Scripted Functions" dialog that appears
will look like this:

3. Use the Function Number spin edit to choose a function that has not yet been defined; that is, one in
which most of the entries in the dialog are blank.
Or simply edit the entries for an existing function to change its definition.

In this example, edit the definition of function 101.

4. After making your changes the dialog should look like this:
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Note that:
(a) The Description must not be blank. If it is blank the function will not appear in the list of available
analysis functions.
(b) The "Ftn is linear in its parameters" checkbox has been checked because the function is linear in
its parameters.
(c) The names "Intercept" and "Slope" have been assigned to the parameters P1 and P2.

5. Click the "Test using default values" button to make sure that the expression is valid and will give the
expected result when evaluated.
The dialog should look like this
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Note that you can change the default X-value and parameter values and test the function evaluation
again.

6. Click the "Save Changes" button to save the scripted function definition.

7. Click the "Done" button. When next setting up an analysis this function will appear in the list of
available functions.
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Change Data Column Order
This "How To" illustrates how to change the order of the data columns in the current data set.

Changing the data column order may be useful in a number of situations. For example:

1. Data that is copied and pasted from another program into FitAll may not have the data columns
organized in the way that the analysis function expects, or

2. You want to analyze the same set of data with two different functions, such as function numbers
0502 and 0512, but the two functions expect the order of the data columns to be different.

Here's how to do it:

1. Open a data file. The result may look like this:

2. Click the menu selections Edit > column Move... (or right-click in the Data window and then click on
the column Move... item in the context menu that appears).

The "Move data columns" dialog will appear and looks like this:

3. Click the "Down" (or "Up") button to change the data column order. The result may look like this:
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4. Click the OK button. The result may look like this:
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Copy Data From a SpreadSheet  Program to FitAll
This "How To" illustrates how to copy data from a spreadsheet program, such as MS Excel, to FitAll.

It is equally applicable to other spreadsheet programs and even text editors and word processors that can
organize and copy columns of data to the MS Windows' clipboard.

The first thing to do is to start FitAll and then create a new data set by clicking the menu selections File >
New.

The "New Data" dialog will appear and looks like this:

Click Def. Names button to assign the standard names to the data columns.

Note: Each FitAll data set must contain at least three columns of data.
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Click the OK button.

FitAll will display its Data window and automatically insert one data point into the data set.

Open Excel or another spreadsheet with a set of data and select (highlight) the columns of data that  are
to be copied to FitAll.

Note: If the column headings (column names) are included in selection they will be pasted into FitAll if
all of the data is in FitAll's data window is to be replaced.
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Press Ctrl+C (or the menu selections Edit > Copy) to copy the selected data to Windows' clipboard.
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Return to FitAll

Press Ctrl+A (or click the menu selections Edit > Select All) to select all of the data in FitAll's data
window.

Press Ctrl+V (or click the menu selections Edit > Paste) to paste the copied data into FitAll.

A warning message, like the one below, may appear.
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Note: Whether a value of zero or one is assigned to the extra data columns is determine by the setting of
the "Set New SigmaY's to 1.0 " checkbox on the "Options > Preferences > Genera l" page.

Click the OK button.

The result should look like this:

Note: Since the data to be pasted consisted of only two columns and the column headings were
included the first two column heading were changed and the third column's values were assigned a
value of one.

To change the data set title and column headings click the menu selections Edit > data Titles.
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Click the Ok button to accept the changes you have made.
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Do a Preliminary Analysis
When you are dealing with data that may not be well described by the fitting function a large number of
iterations may be required before FitAll converges to the final result. To begin, keep the maximum
number of iterations small, for example 10, and the termination criterion large, for example 0.01.

NOTE:
The 'Maximum iterations' and 'Termination criterion' settings are on the Function
tab of the 'Analyze Setup' dialog box which appears when you select Analyze >

Setup  or click the   toolbar button.

Once you have tried the analysis, increase the maximum allowable iterations and/or decrease the value of
the termination criterion to obtain more precise final parameter values.
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do Batch Mode Analyses
Batch Mode Analysis is used to analyze many sets of experimental data to the same function. It is most
useful when a series of experiments are done using a variety of conditions that are expected to yield data
that can be described by the same function.

For example:
When investigating the rate of a chemical reaction, the effectiveness of a
corrosion inhibitor or how acid rain might affect the performance of a solar cell,
one might do a series of experiments that are identical in all respects, except that
the acidity (pH) of the medium in which the experiment is done differs from
experiment to experiment.

Under such circumstances one would expect that the data from each experiment
should be described by the same function (equation).

If the above is the case, it would be useful to 'automatically' analyze each of the
data sets and record the results of the analyses in another data file that can be
viewed and further analyzed.

This is what 'Batch Mode Analysis' (also known as Monte Carlo Analysis) does.

Create the Data Sets

To create data sets that can be used in batch mode analyses:

1. Do a set of experiments that are expected to be fitted to the same function.

2. Save each experiment's data in a file that is named: <basefilename>ddddddd.dta, in which all of
the data files are named so that the names only differ in the number at the end of the name.

The numbers can range from 1 to 2,000,000 and up to seven digits in length.
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Analyzing Batch Mode Data Sets

To analyze a group of data sets do the following:

1. Confirm that your data sets have file names like "basenameddddd.dta", in which the ddddd are
numbers from 0000001 to 2000000 and that all of the files are in the same directory (folder).

NOTES:

1. The numbers in the file name do not have to be contiguous.

When a number in the sequence is missing FitAll will skip the missing file and
continue analyzing the data in the files that are present.

2. The numbers in the filenames can be up to seven digits long. That is, the
numbers may have fewer than seven digits.

2. Load the first file; for example the file named abcd00001.dta.

3. Fit the data using an appropriate function; for example, Function 0001 with 1 term in the background
polynomial and use a weighting factor of 1/(0.1*Y)2.

4. Choose Analyze > Setup  menu selections.

In the 'Analysis Setup' dialog box that appears do the following:

5. On the Function  tab:

· Choose function 0001 (with 1 term in the background polynomial).

· Confirm that the analysis range is the same as you used to analyze the first data set.

· Uncheck the 'Force automatic initial estimates' checkbox, if you want FitAll to use the analysis
results obtained from analyzing the first data set as the starting point for all subsequent analyses.
This is what normally should done when doing Monte Carlo analyses. 

Check the 'Force automatic initial estimates' checkbox, if you want FitAll to automatically make
the initial parameter estimates for each data set that it processes. This is what normally should be
done when doing 'batch mode ' analyses.

· Check the "Monte Carlo (Analyze multiple data sets) checkbox. NOTE that a new tab, the
'Monte Carlo' tab, appears.

6. On the Monte Carlo  tab:

· Use the 'First file...' button to locate the first data file that should be analyzed. For example,
'abcd00001.dta'.

· Use the 'Last file...' button to locate the last data file that should be analyzed. For example,
'abcd00025.dta'.

· Use the 'Results:, Data file...' button to create a file in which the results of the analyses should be
saved. For example: 'abcdResults.dta' in the same file directory (folder) as the data files that are to
be analyzed.

· Use the 'Results: Title and Sub-Title' edit boxes to enter a title and sub-title for the results data
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set. For example: 'Results of abcd analyses with Ftn0001'.

7. Click the OK button

8. Select Analyze > Analyze MonteCarlo data sets , press Alt+N or click the  button.

FitAll will do the analyses, store the results in the results data file  and load the results file into
memory.

9. Select View > Standard stats  to see a summary of the results of the analyses.

Results Data File Structure

The results data file, created when doing a Monte Carlo (or Batch Mode) analysis, contains 2*NTerms+3
columns of data when the nlls or nlad analysis methods are used and 2*NTerms+2 columns of data when
the lls analysis method is used. Nterms is the number of parameters in the analysis function.

For example, if the fitting function contains three parameters, the results data file will contain eight or nine
columns.

The columns contained in the results data file are:

· File Num: The number from the file name of the data file that was analyzed to get the reported results.

· Parameter 1: The resolved value of the function's first parameter

· EE_Parameter 1: The estimated error in parameter 1. If the nlls or lls analysis methods were used, this
corresponds to the estimated standard deviation of parameter 1. If the nllad analysis method was used,
this corresponds to the estimated average deviation of parameter 1.

· ... etc. ...

· ... etc. ...

· Parameter Last

· EE_Last Parameter

· SD_Fit: The standard deviation of the fit.

· Iterations: The number of iterations required to do the fit.

This column is not present when the fitting function is linear in its parameters; that is, when the lls
method is used to analyze the data.
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CAUTION:
When the number of iterations is the same as the Max. Iterations setting it is
likely that FitAll has stopped before the final best fit was obtained. 

[This is more likely to occur when doing 'batch mode' analyses rather than
Monte Carlo analyses].

If this occurs, the best thing to do is:

· Individually re-analyze the data set(s) in question using the 'normal' analysis
type, and / or

· Re-analyze all of the data sets using a larger value for the Max. Iterations
setting.

NOTE:
The beginning of the file may contain a Byte Order Marker, BOM, which specifies
the type of encoding that is used.
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do Monte Carlo Simulation and Analyses
Monte Carlo Simulation and Analysis is used to estimate the error and probability distribution of the
resolved parameters.

To do this:

1. Open the data set that you are interested in and fit the data using an appropriate function.

2. Generate many simulated data sets with the same values of the independent variable(s), X, and the
resolved parameter values and add random errors to the resulting dependent variable, Y.

NOTE:
FitAll's Monte Carlo simulation (data generation) feature uses the currently
loaded data set as the source of the X values.

3. Analyze the generated data sets using the same function and analysis method that was used to
analyze the original data set.

4. The variation and distribution of the resolved parameters can then be used to estimate the errors
(and error distribution) associated with each of the resolved parameters.

NOTE:
FitAll's Monte Carlo analysis feature also can be used to analyze up to a million
data sets to the same function in 'batch mode '.

Simulation

To generate the simulated data sets do:

1. Load the file named 'ABCDTST0.DTA' into memory. (This file contains 100 data points).

2. Fit the data using Function 0001 with 1 term in the background polynomial and a weighting factor of
1/(0.1*Y)2.

3. Choose the Edit > Generate Monte Carlo data sets  menu selection.

In the 'Generate Monte Carlo data sets' dialog box that appears do the following:

4. On the Function  tab:

· Choose function 0001 (with 1 term in the background polynomial).

· Enter a Title and Sub-Title that will be saved with each generated data set; for example, "abcdtest0
Monte Carlo Test".

5. On the Noise  tab:

· Check the 'Add random errors (noise) to Y' check box.

· Select the 'Add noise to Y as: "N * 0.10 * Y"' radio button.

· Set the 'Std. Dev. of the Noise (NSD)' to 1.0.

· Check the 'Average Noise Value' checkbox and set its value to 0, zero.
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· Uncheck the 'Y Value Limit' checkbox.

6. On the Monte Carlo  tab:

· Use the 'Browse' button to select the directory in which you want the generated data files to be
saved.

· Enter a 'Base file name'; for example, "abcd".  FitAll will name the generated data files "Base file
nameddddd.dta", in which ddddd is a five digit number; for example: abcd00001.dta,
abcd00002.dta, ..., and abcd00025.dta.

· Use the 'First and Last file number' spin-edit boxes to enter the first and last numbers that should
be used. For example, if the first and last file numbers are 1 and 25, twenty-five data sets will be
generated. 

7. Click the OK button. The data sets will be generated and saved to disk.
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Analyzing Monte Carlo Data Sets

To analyze a group of data sets do the following:

1. Confirm that your data sets have file names like "basenameddddd.dta", in which the ddddd are
numbers from 0000001 to 2000000 and that all of the files are in the same directory (folder).

NOTES:

1. The numbers in the file name do not have to be contiguous.

When a number in the sequence is missing FitAll will skip the missing file and
continue analyzing the data in the files that are present.

2. The numbers in the filenames can be up to seven digits long. That is, the
numbers may have fewer than seven digits.

2. Load the first file; for example the file named abcd00001.dta.

3. Fit the data using an appropriate function; for example, Function 0001 with 1 term in the background
polynomial and use a weighting factor of 1/(0.1*Y)2.

4. Choose Analyze > Setup  menu selections.

In the 'Analysis Setup' dialog box that appears do the following:

5. On the Function  tab:

· Choose function 0001 (with 1 term in the background polynomial).

· Confirm that the analysis range is the same as you used to analyze the first data set.

· Uncheck the 'Force automatic initial estimates' checkbox, if you want FitAll to use the analysis
results obtained from analyzing the first data set as the starting point for all subsequent analyses.
This is what normally should done when doing Monte Carlo analyses. 

Check the 'Force automatic initial estimates' checkbox, if you want FitAll to automatically make
the initial parameter estimates for each data set that it processes. This is what normally should be
done when doing 'batch mode ' analyses.

· Check the "Monte Carlo (Analyze multiple data sets) checkbox. NOTE that a new tab, the
'Monte Carlo' tab, appears.

6. On the Monte Carlo  tab:

· Use the 'First file...' button to locate the first data file that should be analyzed. For example,
'abcd00001.dta'.

· Use the 'Last file...' button to locate the last data file that should be analyzed. For example,
'abcd00025.dta'.

· Use the 'Results:, Data file...' button to create a file in which the results of the analyses should be
saved. For example: 'abcdResults.dta' in the same file directory (folder) as the data files that are to
be analyzed.

· Use the 'Results: Title and Sub-Title' edit boxes to enter a title and sub-title for the results data
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set. For example: 'Results of abcd analyses with Ftn0001'.

7. Click the OK button

8. Select Analyze > Analyze MonteCarlo data sets , press Alt+N or click the  button.

FitAll will do the analyses, store the results in the results data file  and load the results file into
memory.

9. Select View > Standard stats  to see a summary of the results of the analyses.
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Results Data File Structure

The results data file, created when doing a Monte Carlo (or Batch Mode) analysis, contains 2*NTerms+3
columns of data when the nlls or nlad analysis methods are used and 2*NTerms+2 columns of data when
the lls analysis method is used. Nterms is the number of parameters in the analysis function.

For example, if the fitting function contains three parameters, the results data file will contain eight or nine
columns.

The columns contained in the results data file are:

· File Num: The number from the file name of the data file that was analyzed to get the reported results.

· Parameter 1: The resolved value of the function's first parameter

· EE_Parameter 1: The estimated error in parameter 1. If the nlls or lls analysis methods were used, this
corresponds to the estimated standard deviation of parameter 1. If the nllad analysis method was used,
this corresponds to the estimated average deviation of parameter 1.

· ... etc. ...

· ... etc. ...

· Parameter Last

· EE_Last Parameter

· SD_Fit: The standard deviation of the fit.

· Iterations: The number of iterations required to do the fit.

This column is not present when the fitting function is linear in its parameters; that is, when the lls
method is used to analyze the data.

CAUTION:
When the number of iterations is the same as the Max. Iterations setting it is
likely that FitAll has stopped before the final best fit was obtained. 

[This is more likely to occur when doing 'batch mode' analyses rather than
Monte Carlo analyses].

If this occurs, the best thing to do is:

· Individually re-analyze the data set(s) in question using the 'normal' analysis
type, and / or

· Re-analyze all of the data sets using a larger value for the Max. Iterations
setting.

NOTE:
The beginning of the file may contain a Byte Order Marker, BOM, which specifies
the type of encoding that is used.
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Histogram for One Parameter

When inspecting the results of a Monte Carlo analysis, it may be desirable to see a histogram of the
deviation of a parameter's values from its average.

To do this:

1. Retrieve (File > Open ) the results data file.

2. Use the Edit > column Move  menu selection to move the column containing the parameter of
interest to the second last column position. (In FitAll data sets, this column corresponds to the Y-
values).

3. Fit the data using the Polynomial_1 function.

Set both the 'Smallest exponent in polynomial' and the 'Largest exponent in polynomial' to zero. By
doing this, the data will be fit to the equation: Y = A; that is, the 'best fit' value is the average value.
Also, use a weighting factor of 1.

4. Use the View > residuals distribution graph  menu selections to plot the histogram.

Here are some examples of what the graph may look like:
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NOTE:
The greater the number of data sets analyzed the more likely that the residuals
distribution histogram will look like a "normal" or "Gaussian" curve.
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do Multi-Fit Analyses
Multi-Fit analyses are used to fit one set of data to many different forms (variations) of a single function.

The goal is to identify the variation (form) of the function that provides the best fit.

NOTE:
In FitAll version 8 and later the functions  0024 (Multiple Linear_2),  0208 and
0209 (DNA-Drug Binding) are Multi-Fit enabled.

To do Multi-Fit analyses:

1. Load (File > Open) the data file that you want to analyze using Multi-Fit analysis.

2. Generate a file containing the configurations (variations) of the function that are to be analyzed (Edit
> Generate Multi-Fit Configs... ).

NOTE:
The types of configurations that can be generated depend on the function being
used.

Read the documentation for the function that you are using to get an
understanding of what kinds of configurations (variations) can be generated.

3. Setup the Multi-Fit analysis ( Analyze > Setup, Multi-Fit ).
When setting up the analysis, it is necessary to identify both the file that contains the configurations
and the file into which the results should be saved.

4. Do the analyses ( Analyze > Analyze ).

5. Review the Multi-Fit results.

Generate Multi-Fit Configuration File

1. Retrieve the file named F0024TST01.DTA.

2. Choose Analyze > Setup and select function 0024.

3.

4. Choose Edit > Generate Multi-Fit Configs...

5. Edit the Generate Multi-Fit Configurations dialog box so that it looks like this:
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4. On the Function tab:

· Choose function 0024..Multiple Linear_2 from the Function drop-down list.

· When the 'Number of parameters' dialog box that appears after the function is selected, click the
OK button.

· Click the Config. file name... button to create (or locate) a file that will contain the configuration
information. For example, the file could be named 'C:\Users\Public\FitAll10\DATA\MultiFit-Config-
f0024-01.fmc. 

NOTE:
You can name the file whatever you like as long at the file name extension is
'.fmc', which is an acronym for FitAll Multi-fit Configuration file.

5. In the 'Generate Configuration Numbers' From and To spin-edit boxes enter one, 1, and a number
that is large enough to include all of the possible configurations, for example, 1000.
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NOTE:
The data file F0024TST01.DTA has six (6) columns of independent variables as
well as the Y and SigmaY columns.

Function 0024's Generate Multi-Fit Configurations procedure creates all of the
possible configurations for one to six parameters.

Although the contents of the '.fmc' file can be viewed with a text editor such as
Notepad++, it is most unlikely that you will find this to be a useful endeavour.

6. Click the OK button to generate the configurations.

Analyze Multi-Fit Configurations

To do the Multi-Fit analysis of the configuration were generated in the previous section:

1. Retrieve the file named F0024TST01.DTA.

2. Choose Analyze > Setup....

The Analyze Setup dialog the appears, it looks like this:
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3. On the Function tab:

· Choose function 0024.

· Set the analysis range to include all of the data points.

· Set the Analysis Type to Multi-Fit.

4. On the Multi-Fit tab:

· Click the Configuration file... button and select the previously created file that contains the Multi-Fit
configurations.

· In the Analyze Configuration Numbers From and To spin-edit boxes enter one, 1, and a number
large enough to include all of the configurations. FitAll normally enters the appropriate values.

· Click the Results file... button select or create / open the file into which the results should be saved;
for example, C:\Users\Public\FitAll10\DATA\MultiFit-Config-f0024-01-Results.tdf.

NOTE:
Because the results file has a file name extension of .tdf, the results file will be
saved as a tab-delimited file.

· Enter a Title and Sub-Title for the results data file.

5. Click the OK button.

6. Choose Analyze > Analyze Multi-Fit or click the  button to do the Multi-Fit analyses. The results will
be saved in the results file and be opened by FitAll.
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Review Multi-Fit Results

The Multi-Fit results file should have been automatically opened in  FitAll. If it wasn't or you are reviewing
the results at a later open the results file using the menu selections File > Open.

In this 'How To', the results file only contains 63 results so it can be opened in FitAll. Here's what to do:

1. The data window should look like this:

2. The first column of the results data file  contains the Multi-Fit configuration number and the second
column contains the estimated error of the fit; that is, the standard deviation of the fit.

3. To identify the configuration that gave the best fit, find the row with the smallest value in the EE_Fit
column. The easiest way to do this is to sort the data on the second column. The result of sorting the
results on the EE_Fit column is:

204
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Inspection of the sorted results shows that configurations, MF_Number, 57 and 62 gave the best fit.

4. To view the results of the fit for configuration number 57 in detail, do the following:

· Retrieve (File > Open) the data file (F0024TST01.DTA) that was analyzed.

· Choose Analyze > Setup... and select function 0024, if it is not already selected. The Function tab
of the Analyze Setup dialog box should look like this:
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· On the Multi-Fit tab set the 'Configuration file' and set both the From and To Analyze Configuration
Numbers to 57, because this configuration number corresponds to the best fit. The Multi-Fit tab
should look like this:
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NOTE:
When the From and To Analyze Configuration Numbers fields are equal, FitAll
will retrieve the configuration information and analyze the data, but it will not save
the results to the results file and will not load the results file.

· Click the OK button.

· Choose Analyze > Analyze Multi-Fit or click the  speed-button to do the analysis.

5. The resulting 'Fit Window' should look like this:
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Sort Data
When FitAll does automatic initial estimates of the parameter values it normally expects the data to be
sorted on the first, X, data column.

To sort your data:

· Make the 'Data' window the active window by clicking anywhere in it or by choosing the View > Data
menu selections.

· Choose Edit > Sort  data from the main menu or right click in the data window and choose data Sort
from the context menu.

The 'Sort data on column' dialog box will appear. It looks like this:

· Click the name of the column on which you want to sort the data.

· Click the OK button.
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Spot Data Entry Errors
After entering all or part of a data set, plot it using the View > data graph  menu selections.

Often it will be easy to see if a value was entered incorrectly.

If a data entry error was made, make the 'Data' window the active window and edit the appropriate value.

108
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Verify the Appropriateness of Initial Estimates
After you have selected the function (see, Analyze > Setup ) and estimated the initial parameter values
(see: Analyze > Setup - Parameters tab ) plot the fit (see View > fit graph ) to see if the initial
estimates generate a calculated curve that is reasonably close to the data.

If the calculated curve does not come close to the data points:

· Choose the Analyze > Setup  menu item.

· Click on the Parameters  tab.

· Edit the parameter values.

· Click the OK button.

Once the calculated curve is approximately the same as the data, the actual analysis can be done (see:
Analyze > Analyze ).

NOTE:
The 'Force automatic initial estimates ' check box in the 'Analyze Setup' dialog
on the Function tab sheet should not be checked when you do the analysis. If it is,
your manually adjusted initial estimates will be recalculated before the regression
analysis is done.
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Make Calibration Curves
A calibration curve is a graph of the 'fit' that does not display the data points.

Here's how to do it:

· Retrieve a set of data and analyze it using an appropriate function or use the Edit > Generate data
menu choice to create a set of data with the function that you want to use to create the calibration curve.

· Select View > fit graph .

· Select Edit > Properties  (or right click in the fit graph window and click the Properties item on context
menu).

· Click on the "data series " tab in the Properties dialog box.

· Uncheck the "Points Visible", "Error Bars Visible" and "Confidence Band Visible" checkboxes.

The "data series" tab sheet should look like this:

55

109

81

86



- 179 -

Reference Guide How To, Make Calibration Curves

· Click the OK button. The resulting calibration graph might look like this:

NOTES:

1. You can adjust many of the graph's other properties to customize its
appearance. (See: Edit > Properties, Graph Window ).

2. You also can evaluate the function at a single point using the Analyze > One
point  menu selection.
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Make Graphs with Total and Sub-Component Curves
Some of the functions available in FitAll are the sum of several 'sub-functions' or components.

For example, function number 0302 is the sum of one to five Gaussian curves.

When such a function is analyzed (de-convoluted), the resulting parameters describe each of the
component Gaussian curves that make up the total.

Sometimes, for example in spectroscopy, it may be desirable to plot a graph that shows the total curve as
well as the component curves.

Although FitAll can only plot one calculated curve and one set of data at a time, it is possible to construct
a graph that shows the calculated curve as well as the component curves that make it up.

General Procedure

An Example

181
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General Procedure

Here's how to construct a graph that shows the calculated curve along with the sub-component curves.

1. Retrieve a set of data.

2. Analyze it using the desired function.

3. Record or print the result of the analysis.

4. Use the Edit > Generate data  menu option to create a set of data in which only the component of
interest contributes to the function's value.

To do this, adjust the parameter values so that only one of the components contributes to the
calculated values.

5. Save the generated data for each of the components in a data file.

6. Use the menu options File > Open  and File > Join  to create a new data set that contains the
data for all of the components.

7. Use the Analyze > Setup > Analysis Range  option to set the analysis range so that it includes all
of the data points in the new data set.

8. Use the Analyze > Setup > Parameters  option to manually set the parameter values to the values
that were obtained in step 2 and recorded in step 3.

9. Use the View > fit graph  and Edit > Properties  options to manually scale the graph and set the
plot symbol.

The resulting graph will consist of a solid line for the overall function and a dotted line for each of the
component curves. The spacing between the dots in the dotted lines is determined by the number of data
points that were generated for each component.
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An Example

This example:

· Uses function 0302 to analyze a sample data set, F0302TST.DTA, which is described by and can be
fitted to the sum of two Gaussian curves.

· Creates a graph that displays the overall calculated curve and the two sub-component Gaussian
curves.

Here's what to do:

1. Retrieve the data set named F0302TST.DTA using the File > Open  menu option.

2. Analyze it using function number 0302.
When doing the analysis, you should fit the first 20 points to the function using one Gaussian curve,
then redo the fit using two Gaussians and all of the data.

NOTE:
When a function has more than one form, it will be necessary to 're-select' the
function from the function tab in the Analyze > Setup  dialog.

3. Record or print the results of the analysis.
The results of the analysis should be:

File: c:\Users\Public\fitall10\data\f0302tst.dta

Title: Ftn0302 Test Data: 2 Gaussians

Sub-Title:

Function:
1])/P[3*I]}2] }

Analysis Method: Nonlinear Least Squares (nls)

Analysis Range: 1 to 50 of 50

Weighted as: 1/SigmaY2

Variance: 6.73101600438054E-7

Std. Dev. of Fit: 0.000820427693607458 after 4 iterations

Parameter Name Value Std. Dev.

1 Ypeak1 9.902E+0001 5.658E-0001

2 Xpeak1 6.973E+0000 1.220E-0002

3 FWHH1 3.991E+0000 1.013E-0002
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Parameter Name Value Std. Dev.

4 Ypeak2 7.428E+0001 4.188E-0001

5 Xpeak2 1.499E+0001 9.231E-0003

6 FWHH2 8.010E+0000 5.089E-0003

4. Plot a graph of the fit using the View > fit graph  menu selections.
The graph should look like this:

5. Before generating the component data sets, note that:

· If parameter P1, Ypeak1, is set to zero, the first Gaussian will not contribute to the function's value.

· If parameter P4, Ypeak2, is zero, the second Gaussian will not contribute to the function's value.

6. Click the Edit > Generate data  menu option.

7. Click the Function tab, if it is not already selected.

8. Select function 00302, if it is not already selected.

If, and when, the 'Number of Gaussians' dialog box appears, enter two, 2, and click the OK button.

9. Change the 'Number of points to generate' spin-edit box to 50.
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10. Click on the Parameters  tab.

Change the value of parameter P4 to 0, zero.

57
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11. Click on the Noise tab.

Ensure the 'Add random errors' check box is not checked.
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12. Click on the Variables  tab.

Change the Min. and Max. values of the X1 variable to 0 and 15, respectively.

58
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13. Click the OK button to generate the data.

14. Use the File > Save as  menu selections to save the data in a file named 'TMP1.DTA'.

15. Repeat steps 6 to 13, adjusting the values as follows:

· The 'Number of points to generate' to 50.

· The value of parameter P4 to the value saved in step 3.

· The value of parameter P1 to 0, zero.

· The Min. and Max. values of the X1 variable to 0 and 30, respectively.

16. Save the data in a file named 'TMP2.DTA'.

17. Use the File > Join  menu selections to append the 'TMP1.DTA' data file to the data that is
currently in memory.

18. Use the Analyze >, Setup  menu selections to set the analysis range to 1 to 100.

19. Use the Analyze > Setup > Parameters  tab menu selections to manually set the parameter values
to those obtained in steps 3 and 4.
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20. Use the View > fit graph  menu selections to display the fit graph. It should look like this:109
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Recast a Function
When you have a function that you wish to fit and it does not seem to be available in FitAll, you should
carefully inspect the form of your function and compare it with those in FitAll.

Sometimes it will be possible to rearrange your function so that it is of the same form as one of the
functions included in FitAll.

For example, the function:

does not appear in the list of available functions. It does, however, bare some resemblance to the
cooperative saturation curve (Ftn 0204).

In both functions X is raised to a power and the numerator and denominator are the sum of two terms.

The similarity is sufficiently striking that it is worthwhile to rearrange our function to see if it is the same as
Ftn 0204.

To do this:

· Multiply the numerator and denominator by CB to get: 

· Collect terms using the common denominator (CB + XB) to get: 

· Multiply the numerator and denominator by (1/CB) to get:

This has exactly the same form as Ftn 0204. The parameters are defined as:

P1 = (1/CB), P2 = D, P3 = A and P4 = B.

In other words, the derivation that resulted in Ftn 0204 defined P1 as the reciprocal of CB.

Examples of this type are relatively common in physiology, biochemistry, or chemistry where the
parameter CB is referred to as the "50% dose level" or the dissociation constant, while the parameter
(1/CB) is called the association or formation constant.
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Getting Help
To get technical or other assistance from MTR Software you can:

Visit MTR Software's website at:

www.fitall.com

Email MTR Software at:

support@fitall.com

Write to MTR Software at:

MTR Software

77 Carlton Street, Suite 808

Toronto ON Canada

M5B 2J7

Telephone MTR Software at:

416-596-1499

Describe your problem or difficulty as completely as you can. We will try to answer your query quickly and
completely.

You should also include your email address as well as your daytime, evening and weekend telephone
numbers.

http://www.fitall.com
mailto:support@fitall.com?subject=FitAll Support
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File Structures
DTA Data Files

CSV Data Files

TDF Data Files

SDF Data Files

XXX Data Files

Monte Carlo and Batch Mode Results Files

Multi-Fit Configuration Files

Multi-Fit Results Files

DTA Data Files

Files with the ".DTA" extension are normal FitAll data files. These are UTF-8 or ASCII files that contain
the following information:

<BOM>Number of columns of data

Title of the data set

Heading for column one

Heading for column two

  .

  .

Heading for last column

X[1,1] X[1,2] ... Y[1] SigmaY[1]

X[2,1] X[2,2] ... Y[2] SigmaY[2]

  .

  .

X[I,1] X[I,2] ... Y[I] SigmaY[I]

  .

  .

X[Npts,1] Xpts,2] ... Y[pts] SigmaY[pts]

<BOM> is a "Byte Order Marker" that specifies the type of encoding that has been used. If the data file
only contains ASCII characters the BOM is not present.
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You can prepare a data file with this format using a word processor (in its non-document or ASCII mode)
or a text editor. It will be readable by FitAll.

NOTE:

FitAll usually expects that there will be a minimum of three (3) columns of data,
corresponding to the X, Y, and SigmaY values. However, you can create data
files that contain only two columns of data using a text editor or similar program.

When FitAll encounters such a data file, it will automatically creates a third
column and assign a value of zero or one to each element of the third column,
depending on the Options > Preferences > Set New SigmaY's to 1.0  setting.
This is particularly useful if you have a data acquisition system that creates data
files with only X and Y data.

128
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CSV Data Files

'Comma Separated Values', CSV, data files are assumed to be organized like this:

<BOM>"Title of data set"

"Col1 name","Col2 name","Col3 name", ...

X[1,1],X[1,2],...,Y[1],SigmaY[1]

X[2,1],X[2,2],...,Y[2],SigmaY[2]

   .

   .

   .

X[N,1],X[N,2],...,Y[N],SigmaY[N]

For example:

"Function 1 Test Data"

"X","Y","SigmaY"

1.500E+1,9.790E+1,1.000E+0

3.000E+1,8.550E+1,1.000E+0

4.500E+1,7.470E+1,1.000E+0

6.000E+1,6.530E+1,1.000E+0

7.500E+1,5.700E+1,1.000E+0

9.000E+1,4.990E+1,1.000E+0

1.050E+2,4.360E+1,1.000E+0

1.200E+2,3.810E+1,1.000E+0

1.350E+2,3.330E+1,1.000E+0

4.950E+2,1.000E+0,1.000E+0

The first two lines of the data file are optional. If either, or both, of the lines containing the title and the
column names is missing, FitAll will still read in the data correctly.

<BOM> is a "Byte Order Marker" that specifies the type of encoding that has been used. If the data file
only contains ASCII characters the BOM is not present.

NOTE:

FitAll usually expects that there will be a minimum of three (3) columns of data,
corresponding to the X, Y, and SigmaY values. However, you can create data
files that contain only two columns of data using a text editor or similar program.



- 195 -

Reference Guide Appendix, File Structures

When FitAll encounters such a data file, it will automatically creates a third
column and assign a value of zero or one to each element of the third column,
depending on the Options > Preferences > Set New SigmaY's to 1.0  setting.
This is particularly useful if you have a data acquisition system that creates data
files with only X and Y data.

Also See

XXX Data Files

File, Import Text Data ...
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TDF Data Files

'Tab Delimited File', TDF, files are assumed to be organized like this:

<BOM>Title of data set

Col1 name<Tab>Col2 name<Tab>Col3 name<Tab> ...

X[1,1]<Tab>X[1,2]<Tab>...<Tab>Y[1]<Tab>SigmaY[1]

X[2,1]<Tab>X[2,2]<Tab>...<Tab>Y[2]<Tab>SigmaY[2]

   .

X[N,1]<Tab>X[N,2]<Tab>...<Tab>Y[N]<Tab>SigmaY[N]

in which <Tab> represents the 'Tab' character.

For example:

Function 1 Test Data

X<Tab>Y<Tab>SigmaY

1.500E+1<Tab>9.790E+1<Tab>1.000E+0

3.000E+1<Tab>8.550E+1<Tab>1.000E+0

4.500E+1<Tab>7.470E+1<Tab>1.000E+0

6.000E+1<Tab>6.530E+1<Tab>1.000E+0

7.500E+1<Tab>5.700E+1<Tab>1.000E+0

9.000E+1<Tab>4.990E+1<Tab>1.000E+0

1.050E+2<Tab>4.360E+1<Tab>1.000E+0

1.200E+2<Tab>3.810E+1<Tab>1.000E+0

1.350E+2<Tab>3.330E+1<Tab>1.000E+0

4.950E+2<Tab>1.000E+0<Tab>1.000E+0

The first two lines of the data file are optional. If either or both of the lines containing the title and the
column names is missing, FitAll will still read in the data correctly.

<BOM> is a "Byte Order Marker" that specifies the type of encoding that has been used. If the data file
only contains ASCII characters the BOM is not present.

NOTE:

FitAll usually expects that there will be a minimum of three (3) columns of data,
corresponding to the X, Y, and SigmaY values. However, you can create data
files that contain only two columns of data using a text editor or similar program.
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When FitAll encounters such a data file, it will automatically creates a third
column and assign a value of zero or one to each element of the third column,
depending on the Options > Preferences > Set New SigmaY's to 1.0  setting.
This is particularly useful if you have a data acquisition system that creates data
files with only X and Y data.
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SDF Data Files

'Space Delimited File', SDF, files are assumed to be organized like this:

<BOM>Title of data set

Col1_name<Space>Col2_name<Space>Col3_name<Space> ...

X[1,1]<Space>X[1,2]<Space>...<Space>Y[1]<Space>SigmaY[1]

X[2,1]<Space>X[2,2]<Space>...<Space>Y[2]<Space>SigmaY[2]

   .

X[N,1]<Space>X[N,2]<Space>...<Space>Y[N]<Space>SigmaY[N]

in which <Space> represents one or more " " characters.

For example:

Function 1 Test Data

X<Space>Y<Space>SigmaY

1.500E+1<Space>9.790E+1<Space>1.000E+0

3.000E+1<Space>8.550E+1<Space>1.000E+0

4.500E+1<Space>7.470E+1<Space>1.000E+0

6.000E+1<Space>6.530E+1<Space>1.000E+0

7.500E+1<Space>5.700E+1<Space>1.000E+0

9.000E+1<Space>4.990E+1<Space>1.000E+0

1.050E+2<Space>4.360E+1<Space>1.000E+0

1.200E+2<Space>3.810E+1<Space>1.000E+0

1.350E+2<Space>3.330E+1<Space>1.000E+0

4.950E+2<Space>1.000E+0<Space>1.000E+0

The first two lines of the data file are optional. If either or both of the lines containing the title and the
column names is missing, FitAll will still read in the data correctly.

<BOM> is a "Byte Order Marker" that specifies the type of encoding that has been used. If the data file
only contains ASCII characters the BOM is not present.

NOTE:

FitAll usually expects that there will be a minimum of three (3) columns of data,
corresponding to the X, Y, and SigmaY values. However, you can create data
files that contain only two columns of data using a text editor or similar program.
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When FitAll encounters such a data file, it will automatically creates a third
column and assign a value of zero or one to each element of the third column,
depending on the Options > Preferences > Set New SigmaY's to 1.0  setting.
This is particularly useful if you have a data acquisition system that creates data
files with only X and Y data.
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XXX Data Files

There are many types of "CSV", comma separated values, data files.

It is very difficult for a program, such as FitAll, to automatically determine the exact format that has been
used by other programs to create a ".csv" data file.

In the vast majority of cases, ".csv" data files are organized as described below for the "XXX data file"
data structure.

FitAll's menu selections File, Import Text Data... makes it possible for you to import the data from such
files into FitAll.

XXX data files are assumed to be organized like this:

<BOM><QuoteChar>Title of data set<QuoteChar>

<QuoteChar>Col1 name<QuoteChar><SepChar><QuoteChar>Col2 name<QuoteChar><SepChar> ...

X[1,1]<SepChar>X[1,2]<SepChar>...<SepChar>Y[1]<SepChar>SigmaY[1]

X[2,1]<SepChar>X[2,2]<SepChar>...,Y[2]<SepChar>SigmaY[2]

   .

   .

   .

X[N,1]<SepChar>X[N,2]<SepChar>...<SepChar>Y[N]<SepChar>SigmaY[N]

For example:

Function 1 Test Data

X;Y;SigmaY

1<DecChar>500E+1;9<DecChar>790E+1;1<DecChar>000E+0

3,000E+1;8,550E+1;1,000E+0

4,500E+1;7,470E+1;1,000E+0

6,000E+1;6,530E+1;1,000E+0

7,500E+1;5,700E+1;1,000E+0

9,000E+1;4,990E+1;1,000E+0

1,050E+2;4,360E+1;1,000E+0

1,200E+2;3,810E+1;1,000E+0

1,350E+2;3,330E+1;1,000E+0

4,950E+2;1,000E+0;1,000E+0
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The first two lines of the data file are optional. If either; or both; of the lines containing the title and the
column names is missing; FitAll will still read in the data correctly.

<BOM> is a "Byte Order Marker" that specifies the type of encoding that has been used. If the data file
only contains ASCII characters the BOM is not present.

<DecChar>, which separates the integer part from the fraction part of a number, can be a period, [.], or a
comma [,] character.

<QuoteChar>, which encloses text items, can be nothing, [], a double quotation mark, ["], or a single
quotation mark, ['] character.

<SepChar>, which separates data items, can be a comma, [,], colon, [:], semi-colon, [;], space, [ ] or tab,
[»], character.

NOTE:

FitAll usually expects that there will be a minimum of three (3) columns of data,
corresponding to the X, Y, and SigmaY values. However, you can create data
files that contain only two columns of data using a text editor or similar program.

When FitAll encounters such a data file, it will automatically creates a third
column and assign a value of zero or one to each element of the third column,
depending on the Options > Preferences > Set New SigmaY's to 1.0  setting.
This is particularly useful if you have a data acquisition system that creates data
files with only X and Y data.

Also See

CVS Data Files

File, Import Text Data ...

128

194

12
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Monte Carlo and Batch Mode Results Files

The results data file, created when doing a Monte Carlo (or Batch Mode) analysis, contains 2*NTerms+3
columns of data when the nlls or nlad analysis methods are used and 2*NTerms+2 columns of data when
the lls analysis method is used. Nterms is the number of parameters in the analysis function.

For example, if the fitting function contains three parameters, the results data file will contain eight or nine
columns.

The columns contained in the results data file are:

· File Num: The number from the file name of the data file that was analyzed to get the reported results.

· Parameter 1: The resolved value of the function's first parameter

· EE_Parameter 1: The estimated error in parameter 1. If the nlls or lls analysis methods were used, this
corresponds to the estimated standard deviation of parameter 1. If the nllad analysis method was used,
this corresponds to the estimated average deviation of parameter 1.

· ... etc. ...

· ... etc. ...

· Parameter Last

· EE_Last Parameter

· SD_Fit: The standard deviation of the fit.

· Iterations: The number of iterations required to do the fit.

This column is not present when the fitting function is linear in its parameters; that is, when the lls
method is used to analyze the data.

CAUTION:
When the number of iterations is the same as the Max. Iterations setting it is
likely that FitAll has stopped before the final best fit was obtained. 

[This is more likely to occur when doing 'batch mode' analyses rather than
Monte Carlo analyses].

If this occurs, the best thing to do is:

· Individually re-analyze the data set(s) in question using the 'normal' analysis
type, and / or

· Re-analyze all of the data sets using a larger value for the Max. Iterations
setting.

NOTE:
The beginning of the file may contain a Byte Order Marker, BOM, which specifies
the type of encoding that is used.
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Multi-Fit Configuration Files

The FitAll Multi-Fit configuration file, with the file name extension '.fmc', is created by selecting Edit,
Generate Multi-Fit Configs.... .

NOTES:

1. Although the file can be opened and inspected using almost any text editor, its
contents are unlikely to be of interest to most users.

2. The file's contents should not be modified.

3. The file does not contain a column headings row.

The '.fmc' file is a tab-delimited ASCII file that contains the following columns of data:

· Configuration Number: A number assigned by FitAll to identify the configuration.

· MF_NFVS: The maximum number of 'Function Variation Values' used by the function.

· NFVS: The actual number of 'Function Variation Values' used by this configuration.

· MF_NKonsts: The maximum number of constants, K, used by the function.

· NKonsts: The actual number of constants, K, used by this configuration.

· MF_NTerms: The maximum number of terms, parameters that are to be resolved, by the function.

· NTerms: The actual number of parameters that are resolved (fitted) by this configuration.

· FtnNum: The number of the function that was used to generate the configurations and will be used to
analyze the data.

· FVS-Values: MF_NFVS columns of FVS[] values, beginning with gv.FVS[1]. If NFVS is less than
MF_NFVS the values for the last (MF_NFVS - NFVS) columns are assigned a value of zero. If
MF_NFVS is zero, no values are written to the file.

· K-Values: MF_NKonsts columns of K[] values, beginning with gv.K[1]. If NKonsts is less than
MF_NKonsts the values for the last (MF_NKonsts - NKonsts) columns are assigned a value of zero. If
MF_NKonsts is zero, no values are written to the file.

· P-Values: MF_Terms columns of P[] (parameter) values, beginning with gv.P[1]. These are the initial
estimates of the parameters that are used in the regression analyses. If NTerms is less than
MF_NTerms the values for the last (MF_NTerms - NTerms) columns are assigned a value of zero.
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Multi-Fit Results Files

The Multi-Fit results data file, created when doing Multi-Fit analyses, is a tab- or space-delimited ASCII
file.

The type of file created is determined by the file name's extension when the file is created. If the file name
extension is '.sdf' a space-delimited ASCII file is created, while a file name extension of '.tdf' creates a tab-
delimited file.

Each column in a '.tdf' file is 25 characters wide.

The columns contained in the results data file are:

· MF_Number: Multi-Fit configuration number.

· EE_Fit: Estimated error of the fit. For nlls and lls fits this corresponds to the standard deviation of the fit.
For nlad fits this corresponds to the average absolute deviation of the fit.

· Iterations: The number of iterations required to do the nlls or nlad regression analysis.

This column is not present when the fitting function is linear in its parameters; that is, when the lls
method is used to analyze the data.

CAUTION:
When the number of iterations is the same as the Max. Iterations  setting it is
likely that FitAll has stopped before the final best fit was obtained. 

If this occurs, the best thing to do is:

· Individually re-analyze the data with the configuration(s) in question using the
'normal' analysis type, and / or

· Re-analyze all of the configurations using a larger value for the Max. Iterations
setting.

· MF_FVS: The maximum number of 'Function Variation Values' used by the function.

· FVSn: MF_NFVS columns of FVS[] values, beginning with gv.FVS[1]. If fewer than MF_NFVS FVS's
are actually used by this configuration, the values in the 'extra' columns will be zero.

· MF_NKonst: The maximum number of constants, K, used by the function. If fewer than MF_NKonsts
constants are actually used by this configuration, the values in the 'extra' columns will be zero.

· Constant: MF_NKonst columns of the constant, K, values. If fewer than MF_NKonsts constants are
actually used by this configuration, the values in the 'extra' columns will be zero.

· MF_NTerms: The maximum number of terms, parameters that have been resolved.

· Parameter: MF_NTerms columns of the resolved parameter values. If fewer than MF_NTerms
parameters are actually used by this configuration, the values in the 'extra' columns will be zero.

· EE_Parameter: MF_NTerms columns of the estimated error in the resolved parameter values. If fewer
than MF_NTerms parameters are actually used by this configuration, the values in the 'extra' columns
will be zero.
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Theory Behind FitAll
For functions that are non-linear in their parameters, FitAll uses a non-linear least-squares, gradient-
expansion algorithm developed by Marquardt, which combines the best features of the gradient search
and the linearization methods.

· FitAll also features a unique algorithm for numerically calculating derivatives. This algorithm allows the
program to automatically determine the step-size over which the derivative (or slope) should be
determined.

· Unlike other nonlinear regression programs, FitAll does not require you to enter expressions for the
derivatives of the function or step-sizes.

The analysis methods used by FitAll are discussed in the following sections:

Linear Least-Squares Method

Nonlinear Least-Squares Method

Nonlinear Least Absolute Deviations Method

206
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Linear Least-Squares Method

The least-squares method is used to describe the characteristic response, Y, of a system in terms of
some other quantity (or quantities), X.

The relationship between the dependent variable, Y, (that is, the response) and the independent
variable(s), X, (that is, the stimulus) is expressed in mathematical form by the functional relationship: F =
Y = f(X,P), in which the parameters, P, provide the link between X and Y. This relationship (model) ought
to have a basis in theory, although it is not uncommon for the function f(X,P) to be arrived at empirically.

The data that is collected consists of various measured values of the response, Y[i], and the
corresponding values of the stimulus, X[i].

The sum of the squares of the residuals, S, is given by:

..(1)

The first step in finding the values of the P's that minimize S in the above equation is to differentiate
equation (1) with respect to each of the parameters. This yields a set of equations equal in number to the
number of parameters, Pj, present in the original function. The new equations are:

..(1.1)

..(1.2)

..(1.j)

When the sum of the squares of the deviations, S, is at a minimum, each of the partial derivatives of S ,
dS/dPj, will be equal to zero.

At this point there are j equations in j unknowns, Pj, which can be solved using normal matrix methods.

For functions that are linear in their parameters, P, FitAll uses the linear least-squares method to
determine the parameter values, P.
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Nonlinear Least-Squares Method

If the linear least-squares method is applied to a nonlinear function, the equations corresponding to (1.1)
through (1.j) will not be solvable.

The way around this problem is to first linearize the original nonlinear function. One general method of
linearizing a function is to perform a Taylor expansion to the first order in the parameters, Pj, and defining

a new difference function δF = (F - Fo), in which Fo is the value of the original function, F, evaluated using
some initial estimated values of the parameters, Pj.

For example, with the nonlinear function:

, ..(2)

in which A and B are the parameters, the new difference function, dF , is:

..(3)

Equation (3) is now linear in its (new) parameters, δA and δB. That is, the linearization process transforms
the original function, which had the parameters A and B, into a new function, which has the parameters δA
and δB.

δA and δB represent the changes that must be made to the initial estimates of the values of A and B.

Since equation (3) is linear in its parameters, δA and δB, it can be fitted using the normal linear least-
squares procedure to find values for the new parameters δA and δB.

To obtain the best fit values of the original parameters, A and B, the linear regression must be repeated
several times. With each repetition (iteration), new estimates (A' = A + δA and B' = B + δB) of the original
parameter estimates are made.

When the estimated parameter values no longer change, or when the sum of the squares of the residuals
has reached a minimum, the iterations are halted and the final parameter values are taken to be the best
fit values.

For a more complete discussion of the lls and nlls methods, see:

· Marquardt, D.W. "An Algorithm for Least-Squares Estimation of Nonlinear Parameters" J. Soc. Ind.
Appl. Math., 1963, vol. 11(number 2), page 431.

· Bevington, P.R. Data Reduction and Error Analysis for the Physical Sciences, McGraw-Hill Book Co.,
New York, NY, 1969.

· Press, W.H., Flannery, B.P., Teukolsky, S.A., Vetterling, W.T. Numerical Recipes: The Art of Scientific
Computing, Cambridge University Press, New York, NY, 1986.
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Nonlinear Least Absolute Deviations Method

The non-linear least absolute deviations (nllad) method is very similar to the nonlinear least-squares (nlls)
method. The major difference is that the nllad method minimizes the sum of the absolute deviations rather
than the sum of the squares of the deviations.

The advantages of the non-linear absolute deviations method over the nonlinear least squares method
are:

· The nllad method is less sensitive to the presence of 'outliers'. That is, a few 'bad' data points are less
likely to dramatically affect the values of the resolved parameters.

· The nllad method is less sensitive to the measurement error distribution. That is, the nlls method
assumes a 'normal' (Gaussian) error distribution, while the nllad method does not.

The disadvantages of the nonlinear absolute deviations method are:

· The nllad method usually requires more iterations to obtain the best-fit values.

· The nllad method may require better initial estimates of the parameter values to prevent it from
regressing to a 'false' or 'local' minimum which does not correspond to the 'global' best fit.

For a more complete discussion of the nllad method, see:

· Matheson, I.B.C. "Robust Estimation of Parameters: A Simple Modification to all Non-Linear Fitting
Algorithms to Convert From Minimizing the Sum of Squares of Deviations to Minimizing the Sum of the
Absolute Deviations" Computers in Chemistry, 1989, vol. 13 (number 4), page 299.

· Matheson, I.B.C. "A Critical Comparison of Least Absolute Deviation Fitting (Robust) and Least Squares
Fitting: The Importance of Error Distributions" Computers in Chemistry, 1990, vol. 14 (number 1), page
49.
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Adding Functions to FitAll
There are four ways to add your own specialized functions to FitAll.

1. In FitAll version 10 you can use the new "Scripted Function" feature to add functions that can be
defined by a one-line expression and contains one independent variable, X. and up to ten
parameters, P.

2. You can contact MTR Software to get a quotation on the cost of creating a custom FitAll Function
Library for you.

3. The FitAll Programmer's Guide, which is included with FitAll Research Edition, explains:

· how to modify the supplied source code for the User Defined FitAll Function Libraries and 

· how to compile them using Embarcadero / CodeGear / Borland Delphi version 5 to XE2,
FreePascal version 2.2 or later and Lazarus version 1.0 or later. FreePascal and Lazarus are
open source Pascal compilers available from www.freepascal.org and www.lazarus.freepascal.org
. Lazarus is highly recommended.

4. You can contact MTR Software and request that the function be added to one of FitAll's Function
Libraries.

http://www.freepascal.org
http://www.lazarus.freepascal.org
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Adding UDF Help to FitAll
As of version 9 Update03, FitAll will display help documents for the User Defined Functions, UDFs.

The help files can be MS Word (*.doc, *.docx), Rich Text Format (*.rtf), Open Document Text (*.odt), Text
(*.txt) or Portable Document Format (*.pdf) files.

There are no restrictions on the contents of the help files except those imposed by the document's format
and the application that will display it.

Whether a particular document can be displayed depends on what other software is installed on your
computer and that an association between the file name extension and the application exists.

For example, a '*.docx' file will normally be displayed by MS Word and a '*.txt' file will normally be
displayed by Notepad.

File Names:

The help files must be named like this:

??????FaHelpUDF-####?????????.EXT

in which #### is a four digit number that corresponds to the function's number.
Note that there is a dash, '-', between the F and #### and currently the User Defined Functions are
numbered from 5001 to 6000.

The ???'s can be replaced by any text that is acceptable as part of a file name.

Here are some examples of acceptable names for the help file.

· FaHelpUDF-5001.txt

· FaHelpUDF-5001-FirstUDF-Y=AX+B.doc

· CHM101-FaHelpUDF-5001-FirstUDFforChemistry101-Y=AX+B.docx

· CHM101 Lab05-Kinetics-1st-Order Exponential-FaHelpUDF-5001.docx

· MyName-FaHelpUDF-5001-FunctionForFittingMyData-Y=AX+B.pdf

· MyName-FaHelpUDF-5002-A_Better_Function_For_Fitting_My_Data.odt

NOTE:
Help documents can be created and used for both User Defined Functions that
are compiled into a FitAll Function Library and Scripted functions.

The compiled UDFs will have function numbers from 5001 to 6000 and the
Scripted functions will have function numbers from 0101 to 0200.

File Location:

The help document must be stored in the <FitAll Installation Directory>\Help directory where FitAll was
installed.

By default this will be 'C:\Users\Public\FitAllxx\Help'.
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Sample UDF Help Files:

Several sample help files in different formats are located in the <FitAll Installation
Directory>\Help\Samples directory. 

Copy and rename any of these files, edit them as appropriate and copy the result to the <FitAll Installation
Directory>\Help directory.
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